Pi-hole adalah sebuah aplikasi layaknya aplikasi/plugin Adblock, dimana salah satu fungsinya adalah memblokir iklan yang muncul pada browser. Bedanya dengan aplikasi/plugin Adblock yaitu Pi-hole dapa memblokir iklan pada seluruh client yang terhubung pada jaringan router kita, baik iklan yang muncul pada aplikasi android maupun aplikasi yang lainnya.

Pi-hole cukup efektif untuk memblokir iklan apabila kita menggunakanya di router Mikrotik, jadi akan sedikit menghemat penggunaan bandwith pada jaringan yang dikelola karena iklan yang muncul tidak akan terload. Baca juga: Membahas Cara Kerja Pi-Hole

Pi-hole dapat dijalankan pada hardware dengan spesifikasi yang minimal misalnya raspberry dan STB Android. Pi-hole dapat di install pada sistem operasi (OS) Raspbian, Ubuntu, Debian, Fedora, CentOS. Pada tutorial kali ini saya mencoba menginstall Pi-hole pada OS Ubuntu Server di aplikasi VirtualBox.

Untuk menginstall Pi-hole kita install terlebih dahulu OS Ubuntu Server di VirtualBox dengan konfigurasi Jaringan/Interface terbridge, agar OS Ubuntu Server mendapatkan IP Secara otomatis dari DHCP Server Mikrotik.

Tambahkan file ubuntu dengan tipe file .iso kedalam virtual disk, seperti pada gambar dibawah ini

Kemudian jalankan, akan muncul tampilan instalasi Ubuntu Server

Kemudian akan muncul pilihan bahasa yang akan digunakan, pilih enter untuk melanjutkan

Akan muncul pengaturan untuk konfigurasi Interface/IP Address, karena pada konfigurasi Network di VirtualBox saya buat terbridge maka akan secara otomatis mendapatkan IP dari DHCP Server Mikrotik. Kemudian tekan enter untuk melanjutkan.

Pilih Continue untuk melanjutkan proses instalasi Ubuntu Server

Akan muncul halaman konfigurasi untuk hak akses dan hostname, silahkan isi sesuai dengan keinginan anda. Setelah selesai tekan enter dan pilih done

Karena kita akan menggunakan akses ke SSH jadi ceklislah Install OpenSSH Server. Kemudian pilih done untuk melanjutkan.

Selanjutnya akan muncul halaman instalasi package, karena kita belum memerlukan package ini jadi pada tahap ini di skip saja, dengan memilih tombol done.

Proses instalasi Ubuntu Server, proses ini memerlukan waktu kurang lebih 15 menit, pada proses ini sekaligus akan melakukan proses Update.

Setelah Ubuntu Server berhasil di install di VirtualBox, kemudian download aplikasi Putty untuk mengakses SSH Server. Kemudian masukkan IP Address Ubuntu Server, username dan passwordnya.

Setelah masuk ke SSH Server kemudian jalankan perintah dibawah ini:

curl -sSL https://install.pi-hole.net | bash

Proses instalasi Pi-hole cukup mudah, kita tinggal ikuti saja perintah yang muncul pada halaman Putty.

Setelah Pi-hole berhasil di instal kemudian ubah DNS Server pada Mikrotik menjadi DNS Server Pi-hole.

Tambahkan rule di NAT untuk memaksa seluruh Client memakai DNS Mikrotik, masukkan IP Pi-hole di src-address dan aktifkan tanda ! untuk membuat pengecualian agar IP Pi-hole tidak di redirect ke DNS Mikrotik.

/ip firewall nat
add action=redirect chain=dstnat comment=DNS dst-port=53 protocol=tcp src-address=!192.168.5.96 to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=udp src-address=!192.168.5.96 to-ports=53

Langkah-langkah Cara Install Pi-Hole di Ubuntu Server VirtualBox pada Jaringan Mikrotik akan dijelaskan pada video berikut ini, semoga bermanfaat

1 COMMENT

Leave a Reply