Home Mikrotik Monitoring Neighbord List Dengan Bot Telegram

Monitoring Neighbord List Dengan Bot Telegram

Protokol MikroTik Neighbor Discovery (MNDP) dan LLDP memungkinkan untuk “menemukan” perangkat lain yang kompatibel dengan MNDP atau CDP (Cisco Discovery Protocol) atau LLDP di domain Layer2 (wiki.mikrotik.com). Pada tutorial kali ini saya akan share script untuk memonitoring informasi router yang terdeteksi di Neighbord List dengan Bot Telegram.

Script ini bisa dijalankan dengan menggunakan Schedule pada Mikrotik dengan interval tertentu.

Silahkan klik tombol share ke facebook dibawah ini untuk mendapatkan scriptnya, terimakasih atas dukungan anda

Share to Unlock Contentimage/svg+xml

Silahkan share untuk membuka link download dan membuka scriptnya

Apabila tutorial ini bermanfaat support saya dengan cara share artikel ini.. Terimakasih 

#SCRIPT BY LABKOM.CO.ID
:local bot "BOT ID";
:local chat "CHAT ID";
:local tanggal "Tanggal: $[/system clock get date] %0A";
:foreach neigh in=[/ip neighbor find] do={
:local int ("Interface  ".[/ip neighbor get value-name="interface" $neigh]."%0A")
:local ip ("IP Address ".[/ip neighbor get value-name="address" $neigh]."%0A")
:local mac ("Mac Address ".[/ip neighbor get value-name="mac" $neigh]."%0A")
:local identity ("Identity ".[/ip neighbor get value-name="identity" $neigh]."%0A")
:local version ("Version ".[/ip neighbor get value-name="version" $neigh]."%0A")
:local board ("Board Name ".[/ip neighbor get value-name="board" $neigh]."%0A")
:local uptime ("Uptime ".[/ip neighbor get value-name="uptime" $neigh]." %0A")
/tool fetch url="https://api.telegram.org/bot$bot/sendmessage?chat_id=$chat&text=\E2\9C\85 MONITORING NEIGHBORD: %0A$tanggal $int $ip $mac $identity $version $board $uptime" keep-result=no;
}
:delay 5;

NO COMMENTS

Leave a Reply

Kirim
Baca ketentuan kirim pesan VIA Whatsapp?
Ada pertanyaan seputar tutorial di blog ini?

Silahkan tanyakan melalui kolom komentar dibawah artikel atau melalui video di chanel Labkom TV.

KECUALI..!

1. Ngajak kerjasama
2. Butuh jasa setting
3. Konsultasi (berbayar)
Exit mobile version