Multiprotocol Label Switching (atau disingkat MPLS) merupakan sebuah cara atau metode pengiriman data yang menggunakan label untuk melakukan forwarding packet data. Dengan penggunaan label ini maka pengiriman packet data akan di lakukan dalam sebuah kelompok. Setiap kelompok yang dikirim tidak terkait dengan kelompok lainnya. Dengan penggunaan label dalam transmisi data MPLS merupakan metode transmisi dengan beban proses yang minimal.

  • PE1 – PE3 adalah router Provider Edge yang melakukan Label Popping.
  • P1 – P3 adalah router Provider (Backbone MPLS).

Konfigurasi dibuat menggunakan 6 RB532, tetapi apa pun dengan 3 interface jaringan dan memori 32MB saya rasa cukup untuk pengaturan MPLS pada Mikrotik

Konfigurasi MPLS di Mikrotik

Loopback Interface

Setiap router diatur dengan loop-adapter loop-back yang memegang address loopback.

  • Penggunaan address loopback sebagai address transportasi LDP memastikan perilaku melompat-lompat kedua dari belakang yang tepat ketika beberapa label dilampirkan ke paket seperti dalam kasus VPLS
  • Karena hanya ada satu sesi LDP antara 2 router, tidak peduli berapa banyak link yang menghubungkannya, loopback IP address memastikan bahwa sesi LDP tidak terpengaruh oleh keadaan interface atau perubahan ip address.

Konfigurasi di FE1

/interface bridge add name=bridge-loop
/ip address add address=100.255.255.4/32 interface=bridge-loop

Konfigurasi di FE2

/interface bridge add name=bridge-loop
/ip address add address=100.255.255.5/32 interface=bridge-loop

Konfigurasi di FE3

/interface bridge add name=bridge-loop
/ip address add address=100.255.255.6/32 interface=bridge-loop

P1

/interface bridge add name=bridge-loop
/ip address add address=100.255.255.1/32 interface=bridge-loop

P2

/interface bridge add name=bridge-loop
/ip address add address=100.255.255.2/32 interface=bridge-loop

P3

/interface bridge add name=bridge-loop
/ip address add address=100.255.255.3/32 interface=bridge-loop

Konfigurasi IP Address

Setup the links between the core routers and the core-edge routers as per the diagram:

PE1

/ip address 
add address=100.1.0.1/24 interface=ether1

PE2

/ip address 
add address=100.2.0.1/24 interface=ether1

PE3

/ip address 
add address=100.3.0.1/24 interface=ether1

P1

/ip address 
add address=100.0.255.1/30 interface=ether1 
add address=100.0.255.5/30 interface=ether2
add address=100.1.0.254/24 interface=ether3

P2

/ip address 
add address=100.0.255.6/30 interface=ether1 
add address=100.0.255.9/30 interface=ether2
add address=100.2.0.254/24 interface=ether3

P3

/ip address 
add address=100.0.255.10/30 interface=ether1
add address=100.0.255.2/30 interface=ether2
add address=100.3.0.254/24 interface=ether3

Pengaturan Routing Dinamis

Selanjutnya, kita mengatur OSPF pada setiap router untuk mendistribusikan rute secara dinamis.

P1

/routing ospf 
set distribute-default=never redistribute-connected=as-type-1 router-id=100.255.255.1 
/routing ospf network 
add area=backbone network=100.0.255.0/30 
add area=backbone network=100.0.255.4/30 
add area=backbone network=100.1.0.0/24 

P2

/routing ospf 
set distribute-default=never redistribute-connected=as-type-1 router-id=100.255.255.2
/routing ospf network 
add area=backbone network=100.0.255.8/30 
add area=backbone network=100.0.255.4/30 
add area=backbone network=100.2.0.0/24 

P3

/routing ospf 
set distribute-default=never redistribute-connected=as-type-1 router-id=100.255.255.3 
/routing ospf network 
add area=backbone network=100.0.255.0/30 
add area=backbone network=100.0.255.8/30 
add area=backbone network=100.3.0.0/24 

PE1

/routing ospf 
set distribute-default=never redistribute-connected=as-type-1 router-id=100.255.255.4
/routing ospf network 
add area=backbone network=100.1.0.0/24 

PE2

/routing ospf 
set distribute-default=never redistribute-connected=as-type-1 router-id=100.255.255.5
/routing ospf network 
add area=backbone network=10.2.0.0/24  

PE3

/routing ospf 
set distribute-default=never redistribute-connected=as-type-1 router-id=100.255.255.6
/routing ospf network 
add area=backbone network=100.3.0.0/24

Konfigurasi MPLS

Untuk mendistribusikan label untuk rute, LDP perlu diaktifkan. kita perlu menambah dan mengkonfigurasi sistem MPLS. Maka semua antarmuka yang berpartisipasi dalam MPLS perlu ditambahkan.

PE1

/mpls ldp 
set enabled=yes lsr-id=100.255.255.4 transport-address=100.255.255.4
/mpls ldp interface 
add interface=ether1

PE2

/mpls ldp 
set enabled=yes lsr-id=100.255.255.5 transport-address=100.255.255.5
/mpls ldp interface 
add interface=ether1

PE3

/mpls ldp 
set enabled=yes lsr-id=100.255.255.6 transport-address=100.255.255.6
/mpls ldp interface 
add interface=ether1

P1

/mpls ldp 
set enabled=yes lsr-id=100.255.255.1 transport-address=100.255.255.1
/mpls ldp interface 
add interface=ether1
add interface=ether2
add interface=ether3

P2

/mpls ldp 
set enabled=yes lsr-id=100.255.255.2 transport-address=100.255.255.2
/mpls ldp interface 
add interface=ether1
add interface=ether2
add interface=ether3

P3

/mpls ldp 
set enabled=yes lsr-id=100.255.255.3 transport-address=100.255.255.3
/mpls ldp interface 
add interface=ether1
add interface=ether2
add interface=ether3

Sumber :