Pata tutorial sebelumnya yang berjudul Pembayaran Otomatis di Halaman Login Page Hotspot dengan Payment Gateway kita bisa melakukkan pembelian Voucer Hotspot yang terintegrasi dengan Payment Gateway Xendit, Voucher Hotspot bisa langsung digunakan setelah pelanggan melakukkan pembayaran.

Ada banyak layanan payment gateway yang bisa kita gunakan misalnya DOKU, Xendit, Midtrans, Duitku, iPaymu, Faspay, Mayar. Pada tutorial kali ini saya ingin berbagi bagaimana caranya agar halaman login page hotspot di Mikrotik bisa terintegrasi dengan payment gateway dari Tripay.

Payment TriPay adalah website penyedia layanan payment gateway agregator Indonesia terlengkap, menjadi penguhubung antara merchant & customer melalui satu dashboard simple dengan beragam pilihan jalur pembayaran (sumber: tripay.co.id).

Persiapan

Pada pembuatan login page hotspot dengan Tripay payment gateway ada beberapa tahapan dan kebutuhan yang perlu disiapkan diantaranya yaitu:

  1. Akun Payment Gateway Tripay daftar disini Tripay.co.id.
  2. Hosting, hosting ini digunakan untuk menyimpan dan menjalankan file php, diharuskan menggunakan hosting open port karena dibutuhkan untuk menghubungkan Mikrotik melalui VPN/IP Publik.
  3. Akun VPN Remote, kita bisa menggunakan IP Publik agar hosting dan Mikrotik bisa saling terhubung, jika tidak memiliki IP Publik kita bisa memanfaatkan layanan VPN Remote sebagai alternatif. Untuk membuat akun VPN Remote kita bisa memanfaatkan layanan dari member.labkom.co.id disediakan gratis selama 1 bulan untuk mencoba terlebih dahulu.
  4. File php download disini (File download) password member.labkom.co.id
  5. File databse download disini (File download)
  6. Apa lagi ya???

Langkah-langkah

Walled Garden IP List

Tambahkan juga Walled Garden IP, agar koneksi internet selalu tersedia untuk website payment gateway dan website callbacknya walaupun device belum login hotspot

/ip hotspot walled-garden ip
add action=accept disabled=no dst-host=callback.domainnya.com
add action=accept disabled=no dst-host=tripay.co.id 
add action=accept disabled=no dst-host=assets.tripay.co.id 
add action=accept disabled=no dst-host=stackpath.bootstrapcdn.com 
add action=accept disabled=no dst-host=cdnjs.cloudflare.com 
add action=accept disabled=no !dst-address !dst-address-list dst-host=cdn.jsdelivr.net

Tambahkan juga aplikasi pembayaran misal jika pembayaran pakai DANA

/ip hotspot walled-garden ip add action=accept disabled=no dst-host=m.dana.id

Bersambung>>

Leave a Reply