AdGuard Home adalah software open source yang bisa digunakan di jaringan LAN yang berfungsi untuk memblokir iklan dan tracking dan bisa menjadi kendali atas semua trafik di jaringan LAN kita. Fungsi dari AdGuard Home hampir sama dengan Pi-Hole yaitu sebagai DNS Server, AdGuard Home bisa kita install pada sebuah STB yang dengan OS Armbian Linux. Pada tutorial kali ini saya meneruskan postingan sebelumnya yang berjudul Cara Install AdGuard Home di STB, dimana AdGuard tersebut akan digunakan pada jaringan Mikrotik. Baca juga: AdGuard Home atau Pi-Hole Manakah yang Lebih Baik?

Anggap saja kita telah menginstall AdGuard Home di STB dengan IP 192.168.4.10 dengan port DNS 53, dengan menggunakan port standar untuk DNS yaitu 53, kita cukup menambahkan IP 192.168.4.10 pada DNS Server Mikrotik dengan cara ke menu IP—>DNS.

Agar semua client yang terhubung ke Mikrotik dipaksa untuk menggunakan DNS dari Mikrotik, kita bisa menambahkan rule dibawah ini
/ip firewall nat
add action=redirect chain=dstnat comment=DNS disabled=yes dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat comment=DNS disabled=yes dst-port=53 protocol=udp to-ports=53

Nah sampai sini kita terlah berhasil menggunakan DNS AdGuard Home pada jaringan Mikrotik, tapi bagaimana jika STB mengalami gangguan atau mati? jika STB mati maka bisa saja client tidak bisa mendapatkan akses internet, untuk mengantisipasi hal ini kita bisa memanfaatkan Netwatch untuk memonitoring STB agar ketika STB mati maka DNS Mikrotik akan secara otomatis berganti ke DNS Google.

Caranya buat sebuah Netwatch ke menu Tool–>Netwatch seperti pada gambar dibawah ini

Jika kita menggunakan port lain selain port 53 ada sedikit perbedaan penerapan pada Mikrotik seperti pada video dibawah ini

Leave a Reply