Pada artikel kali ini membahas bagaimana cara membagi koneksi antara dua link ISP menggunakan router Mikrotik untuk memisahkan koneksi YouTube dari satu ISP dan koneksi sisanya melalui ISP lain. Tugasnya adalah memastikan bahwa semua koneksi YouTube dikirim melalui ISP2 sementara semua lalu lintas selain youtube diarahkan melalui ISP1.

Mengapa ada orang yang ingin menerapkan kebijakan seperti yang akan kita terapkan? Salah satu jawabannya adalah memastikan video YouTube dapat mengalir dengan lancar tanpa buffering karena ISP2 dihususkan hanya untuk koneksi youtube saja.

Topologi Jaringan

Langkah

Langkah-langkah yang harus kita lakukan yaitu sebagai berikut:

  1. Buat protokol layer7 untuk trafik YouTube.
  2. Konfigurasikan aturan filter firewall untuk menangkap alamat IP Youtube menggunakan protokol layer7 yang dibuat di atas.
  3. Konfigurasikan aturan mangle routing untuk menandai perutean YouTube untuk alamat IP di daftar alamat Youtube
  4. Konfigurasikan gateway untuk trafik YouTube menggunakan tanda routing yang dibuat pada langkah ketiga.

Implementasi

Untuk menerapkan rule pada router Mikrotik yang akan memerintahkan router untuk mengirim koneksi YouTube dari satu ISP2 dan koneksi sisanya melalui ISP lain, silahkan pastekan rule berikut kedalam new terminal di mikrotik

Membuat protokol layer7 untuk memisahkan koneksi YouTube

/ip firewall layer7-protocol add name=YouTube regexp=^.+(youtube.com).*$

Buat firewall rule untuk menangkap alamat IP YouTube dan letakkan di daftar alamat tujuan

/ip firewall filter add chain=forward action=add-dst-to-address-list layer7-protocol=YouTube src-address=192.168.1.0/24 address-list=youtube_IP_address address-list-timeout=0s

Buat aturan mangle untuk menandai rute untuk alamat IP tujuan di daftar alamat

/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=YouTube_routing dst-address-list=youtube_traffics

Konfigurasikan gateway; satu untuk trafik Youtube dan satu lagi untuk trafik lainnya.

/ip route add dst-address=0.0.0.0/0 routing-mark=Youtube_routing gateway=192.168.11.1 add dst-address=0.0.0.0/0 gateway=10.0.0.10

Jika kita ingin memisahkan koneksi YouTube ke ISP1 jika ISP2 terjadi gangguan, kita dapat mengubah tabel routing dengan perintah sebagai berikut.

/ip route add dst-address=0.0.0.0/0 routing-mark=Youtube_route gateway=192.168.11.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 routing-mark=Youtube_routing gateway=10.0.0.10 distance=2
add dst-address=0.0.0.0/0 gateway=10.0.0.10

Verifikasi

Gambar di atas menunjukkan hasil tracert ke youtube.com dan bbc.com. Anda dapat melihat bahwa sementara jejak ke bbc.com melalui 10.0.0.10 (ISP1) dari youtube.com melalui 192.168.11.1 (ISP2).

Jika artikel ini bermanfaat silahkan share atau berlangganan ke blog ini untuk menerima postingan terbaru yang akan di kirim melalui email dan apabila ingin disebarluaskan harap mencantumkan link sumbernya. Terimakasih

6 COMMENTS

  1. Mau tanya, saya sudah setting dengan menggunakan langkah yang sama, ketika saya tracert masih belum berhasil, ada cara lain?

    • Apakah ketika membuka youtube terdapat penambahan address list di ip-firewall-address list, kalau tidak ada penambahan address list sepertinya protokol layer7 tidak berfungsi

      • saya sudah koreksi ternyata ada yang kliru pada skrip di rule ke 2 dst-address-list=youtube_traffics yang harusnya sama seperti rule pertama yaitu address-list=youtube_IP_address sehingga bisa dijalankan. Terima kasih

Leave a Reply