queue pcq

Pernahkah kita berfikir bagaimana cara untuk membagikan bandwith internet 5Mbps kita secara merata di antara 20 pengguna di jaringan internet kita sedemikian rupa sehingga kecepatan internet orang lain tidak terganggu? Jika ya, mungkin artikel kali ini bisa membantu. Dalam kasus ini, kita akan membahas tentang cara membagi bandwidth secara merata di antara pengguna yang terhubung yaitu dengan menggunakan Mikrotik PCQ.

PCQ Mikrotik yang merupakan singkatan dari per connection classifier, adalah fitur OS router yang memungkinkan seseorang untuk secara dinamis mengantri pengguna yang terhubung dengan menetapkan batas maksimum untuk setiap pengguna. Menggunakan parameter yang ditentukan oleh administrator selama konfigurasi mikrotik pcq, router akan memastikan bahwa setiap koneksi yang ditetapkan terbatas pada kecepatan koneksi yang telah ditetapkan. Ketika dikonfigurasi dengan benar, PCQ memastikan bahwa pengguna yang menggunakan download manager seperti idm atau torrent bit tidak menggunakan seluruh bandwidth yang tersedia sementara pengguna lain terganggu.

Menyiapkan Mikrotik PCQ untuk membatasi download

Untuk mengatur Mikrotik PCQ untuk membatasi download, kita perlu mendefinisikan terlebih dahulu koneksi download yang akan dilewati. Ini akan dilakukan menggunakan aturan mangle. Lihat gambar di bawah.

Menangkap paket pengguna LAN

[php]/ip firewall mangle
add action=mark-connection chain=prerouting src-address=192.168.11.0/24 in interface=ether5 new-connection-mark=office-conn
add action=mark-packet chain=prerouting connection-mark=office-conn new-packet-mark=Lan-packets[/php]

Aturan di atas menangkap paket yang ditujukan ke alamat LAN (192.168.11.0/24) saat mereka masuk melalui antarmuka WAN (ether1). Aturan ini akan digunakan dalam langkah selanjutnya.

Konfigurasi PCQ Mikrotik

Di sini, kita akan membuat dua aturan pcq: satu untuk download dan yang lainnya untuk upload. Lihat di bawah

[php]
/queue type
add name=Office-down kind=pcq pcq-rate=1M pcq-limit=50KiB  pcq-classifier=dst-address pcq-total-limit=2000KiB pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-src-address-mask=32 pcq-dst-address-mask=32 pcq-src-address6-mask=64 pcq-dst-address6-mask=64
add name=office-up kind=pcq pcq-rate=1M pcq-limit=50KiB pcq-classifier=src-address pcq-total-limit=2000KiB pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-src-address-mask=32 pcq-dst-address-mask=32 pcq-src-address6-mask=64 pcq-dst-address6-mask=64
[/php]

Dari perintah di atas, kita dapat melihat nama antrian diatur ke “Office-up” dan “Office-down” sementara jumlah total antrian dinamis yang dapat ditetapkan diatur ke 50. Karena kita hanya ingun 2 pengguna yang terhubung, Kita asumsikan koneksi yang sudah ada tidak dapat melebihi 50. Jika kita memiliki hingga 200 pengguna di jaringan kita akan lebih efektif jika anda menaikkanmenaikk 300 atau lebih, tetapi ingatlah bahwa semakin banyak antrean, semakin banyak RAM dan prosesor yang dibutuhkan dari router Anda. Setiap pengguna akan dibatasi untuk mengupload 1Mbps dan mengunduh dari total bandwidth yang disediakan oleh ISP. Ini berarti bandwidth maksimum yang dapat ditarik oleh setiap pengguna yang terhubung adalah 1Mbps.

Selanjutnya, kitakita  menerapkan pohon antrian menggunakan pcq yang dibuat di atas dan aturan mangle yang dibuat pada langkah pertama. Ada dua pendekatan untuk ini. Anda dapat menetapkan tingkat maksimal untuk semua pengguna yang terhubung. Dengan begitu, jumlah konsumsi bandwidth pengguna yang terhubung tidak dapat melebihi angka yang Anda tetapkan. Untuk melakukan ini, pertama buat antrian yang akan digunakan sebagai antrian parent untuk yang berikutnya. Lihat kode di bawah:

[php]
/queue tree
add name=”download” parent=total-bandwidth packet-mark=office-pack limit-at=0 queue=Office down priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s bucket-size=0.1
add name=”upload” parent=total-bandwidth packet-mark=office-pack limit-at=0 queue=office-up priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s bucket-size=0.1
add name=”total-bandwidth” parent=global packet-mark=office-pack limit-at=3M queue=default-small priority=8 max-limit=3M burst-limit=0 burst-threshold=0 burst-time=0s bucket-size=0.1
[/php]

Anda tidak perlu mengatur antrian pertama pada gambar di atas. Cukup tetapkan aturan 2 dan 3 untuk memastikan bahwa parent disetel ke global. Dengan begitu, setiap pengguna yang terhubung dapat bandwith yang maksimal 1Mbps dari bandwith yang diberikan oleh ISP. Selanjutnya, pengguna mungkin tidak dapat bandwith hingga 1Mbps. PCQ dapat membantu menghentikan pengguna melampaui batas bandwidth yang ditentukan tetapi tidak menjamin bahwa pengguna dapat naik ke kecepatan tertentu setiap saat.

Jika artikel ini bermanfaat silahkan share atau berlangganan ke blog ini untuk menerima postingan terbaru yang akan di kirim melalui email dan apabila ingin disebarluaskan harap mencantumkan link sumbernya. Terimakasih

1 COMMENT

  1. gan, maaf mau tanya. saya sudah mengikuti totur agan hingga selesai dan berhasil tp ketika rate pcq download saya naikin jd 2 Mb begitu saya speedtest untuk uploadnya ikut 2 Mb juga. padahal di queue type rate pcq uploadnya ga saya naikin gan. itu kenapa ya gan?

Leave a Reply