Pada tutorial kali ini Saya akan membahas bagaimana caranya konfigurasi service VPN di MikroTik atau OpenVPN dengan koneksi Client Windows. Jadi teman-teman bisa mengkoneksikan OpenVPN dari Mikrotik dengan koneksi Client ke Windows.

Sedikit berbeda dengan konfigurasi OpenVPN dari Mikrotik ke Mikrotik, hanya saja untuk konfigurasi di Server OpenVPN sama saja. Berbeda dengan koneksi pptp yang sudah saya bahasa pada postingan sebelumnya yang berjudul Membuat Koneksi VPN/PPTP Mikrotik ke Android, dimana koneksi pptp tidak memerlukan certificate ssl/tls. Karena koneksi OpenVPN memerlukan Certificate tls/ssl tentunya cukup aman karena koneksinya sudah terenskripsi.

Untuk membuat koneksi OpenVPN Server di Mikrotik, tidak ada bedanya dengan koneksi pptp, sstp atau l2tp, hanya saja untuk koneksi OpenVPN, teman-teman harus membuat Certificate terlebih dahulu. Untuk membuat Certificate yang digunakan oleh OpenVPN teman-teman bisa membuatnya di Mikrotik yang akan dibahas pada tutorial kali ini. Atau teman-teman juga bisa membuat Certificate SSL/TLS dengan menggunakan pihak ketiga misalnya dari SSL For Free atau dari Cpanel

Baca juga:

Buat Certificate dengan Mikrotik

Untuk membuat Certificate untuk OpenVPN kita juga bisa menggunakan Certificate yang di generate oleh Mikrotik dengan cara, jalankan script ini di New Terminal

/certificate add name=yayan common-name=yayan days-valid=730

Jalankan perintah sign untuk Certificate yang telah dibuat

/certificate sign yayan ca=CA name=yayan

Export Certificate

/certificate export-certificate export-passphrase=123456

Buat IP Pool Mikrotik

IP Pool ini akan digunakan untuk client VPN

/ip pool add name=OPENVPN_POOL range=172.31.31.100-172.31.31.200

Buat Server OpenVPN Mikrotik

Setelah membuat certificate langkah selanjutnya yaitu membuat OpenVPN Server caranya ke menu PPP–> OVPN Server, kemudian ceklis Enable.

/interface ovpn-server server
set auth=sha1 certificate=CA cipher=aes256 default-profile=OPENVPN enabled=yes require-client-certificate=yes

Buat sebuah profile baru untuk OpenVPN dan gunakan IP Pool yang telah dibuat tadi

/ppp profile add name=OPENVPN local-address=172.31.31.1 dns-server=172.17.0.254 only-one=yes rate-limit=20M/20M remote-address=OPENVPN_POOL session-timeout=1d

Setelah OpenVPN Server diaktifkan selanjutnya buat PPP Secret. PPP Secret digunakan untuk akses ke OpenVPN Server.

/ppp secret add name=labkom password=labkom profile=OPENVPN service=ovpn

Cara Koneksikan OpenVPN di Windows

Untuk mengkoneksikan koneksi OpenVPN Mikrotik, kita bisa menggunakan aplikasi dari openvpn.net bisa di download disini https://openvpn.net/community-downloads/. Kemudian instal aplikasi OpenVPN tersebut

Buat profile OpenVPN

Buat file baru dengan bisa dibuat dengan notepad kemudian simpan dengan ekstensi .ovpn, script dibawah ini kemudian simpan di C:\Program Files\OpenVPN\config\nama folder

dev tun
proto tcp-client
remote (IP Public OpenVPN Mikrotik) 1194
ca cert_export_CA.crt
cert cert_export_sopyan.crt
key cert_export_sopyan.key
tls-client
port 1194
persist-tun
persist-key
mute-replay-warnings
verb 3
cipher AES-256-CBC
auth SHA1
pull
auth-user-pass secret
route 172.17.0.1 255.255.255.0 172.31.31.1
dhcp-option DOMAIN labkom.co.id

Kemudian buat file baru dengan tipe .txt, dengan isinya username dan password Secrets OpenVPN Mikrotik, isinya

labkom

labkom

Pindahkan File Certificate

Di File manager akan ada file baru dengan tipe file .crt dan .key, pindahkan file tersebut yang nantinya akan digunakan untuk certificate client OpenVPN kedalam folder C:\Program Files\OpenVPN\config\nama folder

10 COMMENTS

Leave a Reply