Pada tutorial kali ini saya akan membahas cara membuat server PPPOE untuk pelanggan bulanan, jadi dengan sistem yang akan saya buat ini ketika pelanggan PPPOE bulanan terkoneksi pertama kali ke server PPPOE akan dibuatkan sebuah scheduler baru dengan interval 30d atau 30 hari dengan menjalankan sebuah script untuk memutus koneksi PPPOE pelanggan yang akfif, dan mengganti nama profile untuk pelanggan tersebut degan nama profile expire, yang nantinya akan berfungsi sebagai notifikasi/pemberitahuan atau akan menampilkan halaman isolir. Untuk membuat halaman isolir akan dibahas pada tutorial berikutnya.

PPPoE SERVER (POINT TO POINT PROTOCOL OVER ETHERNET)

PPPoE atau Point to Point Protocol over Ethernet adalah pengembangan dari PPP (Point to Point Protocol). PPP sendiri adalah Protocol Point to Point yang digunakan untuk menghubungkan langsung antara perangkat satu dengan perangkat lain nya. PPP diterapkan pada serial Modem, agar modem tersebut terhubung langsung atau face-to-face dengan ISP.

Buat IP Pool

Buat IP Pool yang digunakan husus untuk client PPPoE dimana IP Pool yang dibuat ada dua, yaitu:

  • IP Pool PPPOE: 192.168.2.3-192.168.2.254
  • IP Pool Expire: 10.10.10.2-10.10.10.254

Tambahkan IP Address

Buat PPP Profile

Saya membuat dua PPP Profile seperti pada gambar dibawah ini, dan atur limit sesuai yang diinginkan.

Tambahkan script, scipt ini akan membuat sebuah scheduler baru dengan interval 30d, jadi setelah 30 hari user PPPoE akan di diskonek, dan mengganti profile tersebut ke profile Expire

{
:local usernya $user;
:if ([/system schedule find name=$usernya]="") do={
/system schedule add name=$usernya interval=30d on-event="/ppp secret set profile=Expire [find name=$usernya]\r\n/ppp active remove [find name=$usernya]\r\n/system schedule remove [find name=$usernya]"
}
}

Profile untuk Expire

Buat PPPoE Server

Selanjutnya buat PPPoE Server dan masukkan nama interface yang akan digunakan untuk PPPoE

Scheduler Masa aktif Bulanan

Ketika pelanggan bulanan pertama kali terhubung ke server PPPoE maka akan membuat sebuah scheduler sesuai dengan nama di ppp secret

Scheduler ini akan mengganti profile ke Expire, menghapus pelanggan PPPoE yang aktif dan menghapus Scheduler tersebut

Menghubungkan ke Komputer

Untuk menghubungkan PPPoE Server Mikrotik ke Komputer caranya tambahkan sebuah koneksi Broadband (PPPoE), kemudian masukkan username dan password PPPoE

Blokir Pelanggan Expire

Untuk Memblikir pelanggan Expire tambahkan dulu Address List untuk pelanggan Expire, sesuai dengan IP Pool yang telah dibuat tadi

Drop koneksi address list expire

/ip firewall filterr add chain=forward action=drop src-address-list= Expire

Baca juga:

Membuat Halaman ISOLIR untuk Pelanggan PPPoE Bulanan

20 COMMENTS

  1. Apa kelebihan kekurangan pppoe sama hotspot ya gan..?? Krn sy walau pelanggan Pk PC sy ttp pake hotspot meski colok lan ke pc akan auto nongol login page di browsernya..lbh simple..
    klo pppoe sy blm pernah coba..jd blm tahu plus minusnya.

  2. mau tanya apakah bisa untuk hari kita buat menjadi 37 hari, jadi masih ada jangka waktu 7 hari untuk pembayaran sebelum internet benar2 di redirect

  3. Gan apakah bisa pppoe hanya menggunakan 1 ether port untuk beberapa user, pembaginya menggunakan switch murah
    Urutannya jaringannya jadi
    Modem-mikrotik-switch-client 1,client 2, client 3

  4. Gan sy masih bingung dengan scriptnya, disana dituliskan ( user ), apakah user yang dimaksud adalah user yang kita buat untuk ppoe client? Jadi jika kita membuat nama user dengan joko, maka pada script tersebut kita ganti user dengan joko?

Leave a Reply