Halaman isolir merupakan sebuah halaman web yang menampilkan sebuah informasi bahwa layanan internet tidak dapat digunakan karena telat melakukan pembayaran. Agar layanan internet dapat digunakan kembali, pelanggan PPPoE diharuskan melakukan pembayaran, nah pada tutorial kali akan menjelaskan bagaiaman cara membuat halaman ISOLIR bagi pelanggan PPPoE.

Pada tutorial kali ini melanjutkan tutorial sebelumnya yang berjudul Membuat Server PPPOE Untuk Pelanggan Bulanan, pata tutorial tersebut dijelaskan cara membuat user Profile untuk pelanggan PPPoE dan Pelanggan yang telah Expire, dengan menggunakan script dan scheduler pelanggan PPPoE akan secara otomatis terputus/disconnected koneksi internetnya telat melakukan pembayaran.

Sebagai gambaran pada konfigurasi untuk membuat halaman isolir saya menggunakan Web Proxy Mikrotik, kemudian disediakan IP Pool untuk pelanggan Expire : 10.10.10.2-10.10.10.254. Kemudian IP tersebut akan di redirect ke port web Proxy Mikrotik dengan menggunakan NAT.

Tutorial ini cocok bagi teman-teman yang menggunakan sistem PPPoE dengan pelanggan bulanan, dimana ketika pelanggan PPPoE yang terisolir akan menampilkan halaman pemberitahuan seperti gambar dibawah ini:

Sebagai contoh bisa mendownload halaman isolir disini: Download Halaman Isolir

Untuk membuat halaman isolir bagi pelanggan PPPoE aktifkan dulu Web Proxy Mikrotik, ke menu IP–>Web Proxy.

Tambahkan NAT untuk meredirect koneksi dari IP Pool pelanggan Expire ke port web proxy 8080

/ip firewall nat
add chain=dstnat action=redirect to-ports=8080 protocol=tcp src-address-list=Expire dst-port=80,443

Tambahkan access web proxy

/ip proxy access
add action=allow dst-port=8080 src-address=10.10.10.0/24
add action=deny dst-host=!labkom.co.id redirect-to=192.168.5.1:8080 src-address=10.10.10.0/24
add action=deny dst-port=8080 redirect-to=google.com src-address=192.168.5.0/24
add action=deny dst-port=8080 redirect-to=google.com src-address=192.168.2.0/24
add action=deny

Saya memiliki IP Client hotspot 192.168.5.0/24 dan IP Client PPPoE 192.168.2.0/24, apabila client tersebut mengakses webroxy maka akan di redirect ke google.com. Rule ini hanya opsi saja

add action=deny dst-port=8080 redirect-to=google.com src-address=192.168.5.0/24
add action=deny dst-port=8080 redirect-to=google.com src-address=192.168.2.0/24

Kemudian rule add action=deny bertujuan apabila jika ada IP Selain IP Client yang sudah di tambahkan di src Address mengakses webproxy maka koneksinya akan ditolak, jadi hanya IP tertentu saja yang dapat mengakses webproxy.

Edit halaman error.html, ketika mengakses web proxy mikrotik halaman error.html akan di tampilkan, jadi Saya akan mengedit halan tersebut menjadi halaman ISOLIR. Download halaman Isolir dibawah ini

Download halaman isolir dibawah ini

Halaman isolir pelanggan PPPoE Bulanan
Halaman isolir pelanggan PPPoE Bulanan

Kemudian edit terlebih dahulu dengan menggunakan Notepad sebelum di upload ke file manager Mikrotik. Setelah di edit kemudian pindahkan file tersebut ke file manager Mikrotik didalam folder webproxy.

Blokir Pelanggan Expire

Untuk Memblikir pelanggan Expire tambahkan dulu Address List untuk pelanggan Expire, sesuai dengan IP Pool yang telah dibuat tadi

Drop koneksi address list expire

/ip firewall filterr add chain=forward action=drop src-address-list=Expire

Tutorial lengkap cara Membuat Halaman ISOLIR untuk Pelanggan PPPoE Bulanan teman-teman bisa tonton video dibawah ini. Jangan lupa subscibe juga chanelnya ya…

Baca juga:

UPDATE 23 MARET 2020

Apabila halaman isolir tidak mau muncul dengan keterangan error ERR TO MANY REDIRECTS, itu karena masalah di Web Proxy Access, silahkan coba gunakan hanya rule ini saja dan hapus rule yang telah dibuat pada tahap sebelumnya.

/ip proxy access
add action=allow dst-port=8080 src-address=10.10.10.0/24
add action=deny dst-host=!labkom.co.id redirect-to=192.168.5.1:8080 src-address=10.10.10.0/24 dst-address=!192.168.5.1 dst-port=80

Dan pastikan halaman webproxy berhasil di akses dengan mencobanya membuka di web browser dengan alamat 192.168.5.1:8080

Hasilnya apabila ada client selain pelanggan ISOLIR yang mencoba mengakses halaman Web Proxy Mikrotik maka akan menampilkan halaman isolir ini dan tidak di redirect ke halaman google.com

Tambahan

Selama pengujian CPU kadang naek yang sumbernya dari Webproxy, solusinya blokir akses ke webproxy. Dan simpan di urutan paling bawah

/ip proxy access
add action=deny

17 COMMENTS

  1. mas yayan bisa di bantu punyaku di remot. sampean kasi halaman isolir juga saat gak ada internet langsung pindah ke halaman perbaikan sever maintenance dengan biaya brp…???

  2. Pak ingin tanya, saya ikutin langkah2 diatas tampilan hompega isolir muncul, ada yng ingin sya tanyakan. jika pelanggan menggunaan PPPoE yang di conect menggunakan akses point contohnya huawei dengan client HP dan Laptop mendapat Ip dari akses pointnya dan ipnya berbeda dengan ip PPPoE, yang saya tanyakan bagaimana menampilkan hompega isolir di client dengan ip client yang diberikan akses point.

    Terima kasih.

Leave a Reply