Ada dua tipe pelanggan Hotspot yang sering kita gunakan, yaitu pelanggan Voucheran dan Pelanggan Bulanan. Untuk pelanggan Voucheran tentunya tidak ada masalah karena ada aplikasi seperti Mikhmon untuk mengelola Voucher Hotspot. Nah bagaimana caranya membuat pelanggan bulanan dengan sistem Hotspot dimana setiap device pelanggan di bypassed, kemudian untuk setiap bulan bagi pelanggan yang belum melakukan pembayaran pada saat tanggal jatuh tempo akan menampilkan informasi terisolir?

Untuk membuat sistem seperti itu tidak cukup dengan menggunakan Mikhmon saja, ada cara dan triknya. Nah caranya akan saya bahas pada tutorial kali ini.

Buat User Profile Bulanan

Untuk membuat pelanggan bulanan kita buat dulu sebuah User Profile yang digunakan untuk pelanggan bulanan dimana user tersebut harus login setelah pelanggan tersebut terisolir, jika pelanggan belum bayar maka akan menampilkan halaman isolir, jika pelanggan telah membayar bisa mengakses internet, selanjutnya akan di bypassed kembali setelah user tersebut logout.

Dengan menambahkan script ini di On Logout User Profile, maka akan mengganti dari Reguler menjadi Bypassed ketika logout, berdasarkan IP Address. Dan mendisable user tersebut.

:local nama "$user";
:local ip "$address";
/ip hotspot ip-binding set type=bypassed [find address=$ip];
/ip hotspot user disable [find name=$nama];

Buat Script dan Schedule

Jalankan script ini dengan menggunakan Schedule dengan interval 1d. Ubah $varDay = “5”, sesuai tanggal jatuh tempo yang di inginkan. Misalnya pada gambar dibawah ini saya menjalankan script ini pada pukul 04:00:00 dengan interval 1d. Dengan asumsi pada pukul tersebut pelanggan tidak sedang menggunakan internet.

Script ini berfungsi apabila tanggal Mikrotik = 5, maka akan menjalankan 4 perintah.

  1. Mengganti limit-uptime=00:00:01, dengan kriteria profile bulanan dan memiliki komentar selain lunas
  2. Menghapus komentar dengan kriteria comment=lunas
  3. Mengganti ip-binding, dengan mengganti type menjadi reguler
  4. Mengaktifkan user Bulanan.
:local varDate;
:local varDay;
:set varDate [/system clock get date];
:set varDay [:pick $varDate 4 6];
:if ($varDay = "5") do={ 
/ip hotspot user set limit-uptime=00:00:01 [find profile=Bulanan comment!=lunas];
/ip hotspot user set comment="" [find comment=lunas];
/ip hotspot ip-binding set type=regular [find];
/ip hotspot user enable [find profile=Bulanan];
}

Kemudian untuk setiap bulanya menjelang jatuh tempo, apabila ada user yang membayar, kita cukup menambahkan komentar “lunas”, maka user tersebut diharuskan login dan selanjutnya akan di bypassed ketika logout.

Maka ketika jatuh tempo semua user dengan profile bulanan dan tidak ada komentar “lunas” maka akan di ubah limit uptime menjadi 00:00:01, dengan cara menambahkan limit uptime kita bisa membuat halaman isolir untuk pelanggan yang belum membayar, cara dengan mengedit halaman login.html.

Membuat Halaman Isolir

Untuk membuat halaman isolir untuk pelanggan bulanan dengan sistem bypassed, kita buat dulu halaman isolirnya dengan nama isolir.html dan menyimpanya di folder hotspot.

Di halaman login.html, apabila ada user/voucher yang menampilkan pesan error uptime limit reached, akan di redirect ke halaman isolir.html

Pesan error uptime limit reached muncul karena pada tahap sebelumnya User Limit Uptime telah diubah nilainya menjadi 00:00:01 bagi pelanggan yang belum membayar.

if(error=="uptime limit reached"){
document.location.href="./isolir.html";
}

Dan pastikan di file error.txt untuk kriteria dengan format uptime-limit = uptime limit reached.

nah seperti itu langkah-langkah Membuat Isolir Pelanggan Hotspot Bulanan yang di Bypassed setiap Awal Bulan

Penjelasan lebih lengkap akan saya buat video langkah-langkahnya. Jangan lupa subscribe dulu bagi teman-teman yang belum subscribe Chanel Labkom TV hehe

Baca juga:

Leave a Reply