Pada tutorial sebelumnya yang berjudul Membuat Halaman ISOLIR untuk Pelanggan PPPoE Bulanan, hanya berfungsi bagi pelanggan bulanan dimana halaman isolir akan muncul ketika jatuh tempo terhitung dari pertama kali pelanggan tersebut mengakses internet melalui koneksi PPPoE. Dengan cara mengganti profile pelanggan PPPoE maka halaman isolir akan muncul. Nah bagaimana caranya agar semua pelanggan PPPoE jatuh temponya setiap tanggal 5?

Pada tutorial kali ini saya akan share script untuk mengganti profile dan memutus koneksi PPPoE yang aktif apabila telah jatuh tempo, yaitu setiap tanggal 5 tiap bulannya. Dengan cara ini bisa dikombinasikan dengan Halaman isolir yang sudah dibahas pada tutorial sebelumnya, halaman isolir merupakan sebuah halaman web yang menampilkan sebuah informasi bahwa layanan internet tidak dapat digunakan karena telat melakukan pembayaran. Agar layanan internet dapat digunakan kembali, pelanggan PPPoE diharuskan melakukan pembayaran.

Untuk script ini akan mengecek tanggal pada mikrotik, apabila tanggal 5 akan menjalankan script untuk mengganti profile pelanggan PPPoE dan memutus koneksi PPPoE yang masih aktif.

Konfigurasi SNTP Client

Karena script ini mengharuskan tanggal pada Mikrotik diseting dengan benar maka pastikan SNTP Client sudah diseting dengan benar, teman-teman bisa menggunakan server SNTP dari website berikut https://www.pool.ntp.org/zone/id. Dengan cara ke System–>SNTP Client, apabila terlebih dahulu dan isi Primari NTP Server dan Secondary NTP Server. Seperti contoh pada gambar dibawah ini:

Ketika mikrotik di restart atau reboot maka akan menggunakan konfigurasi tanggal dan waktu default, agar tanggal dan waktu terupdate harus terkoneksi ke internet terlebih dahulu, nah untuk menghindari gagal update tanggal dan waktu ketika koneksi internet terjadi gangguan kita bisa menggunakan script untuk konfigurasi tanggal dan waktu secara otomatis dari tanggal dan waktu sebelum Mikrotik di reboot.

Update Otomatis Tanggal dan Waktu

Buat script dengan nama updateDateTime, isi script kosongkan saja

lalu buat scheduler dengan nama updateDateTime, isi scheduler dengan script dibawah ini. Scheduler ini akan mengupdate isi script updateDateTime, dengan tanggal dan waktu sekarang. Jalankan sesuai dengan interval yang diinginkan.

:local date [sys clock get date]; 
:local time [/sys clock get time]; 
/sys scr set source="/sys clock set date=$date time=$time" [find where name=updateDateTime];

Kemudian buat scheduler lagi untuk menjalankan script updateDateTime ketika Mikrotik baru menyala.

Dengan cara ini tanggal dan waktu Mikrotik akan selalu terupdate apabila Mikrotik di Reboot atau tidak ada koneksi internet.

Script Ganti profile PPPoE

Buat script dengan nama isolir, script ini mengecek apakah Mikrotik memiliki tanggal 5, apabila iya, script ini akan mengganti profile menjadi Expire selain yang memiliki komentar lunas, menghapus komentar selain secret yang memiliki komentar lunas, kemudian menghapus koneksi PPPoE yang aktif.

:local varDate;
:local varDay;
:set varDate [/system clock get date];
:set varDay [:pick $varDate 4 6];
:if ($varDay = "05") do={ 
/ppp secret set profile=Expire [find comment!=lunas];
/ppp secret set comment="" [find comment=lunas];
/ppp active remove [find];
}

Buat scheduler untuk menjalankan script dengan nama isolir, jalankan setiap pukul 1 malam, dengan interval 1d (1 hari).

Untuk menandai pelanggan PPPoE telah membayar dan belum membayar tambahkan komentar “lunas” pada setiap Secrets PPPoE.

Baca juga

Referensi: https://laksa19.github.io

2 COMMENTS

Leave a Reply