Memisahkan Bandwith Dengan 3 Isp yang Berbeda dengan Routing Mark Mikrotik

4
1308

Pada kasus ini kita akan membahas tentang cara menggunakan routing mark pada mikrotik untuk memisahkan bandwith dengan 3 isp yang berbeda, contoh kasus kita memiliki 3 isp dari ISP INDIHOME, ISP ASTINET dan ISP MYREPUBLIC . Jika Anda memiliki beberapa koneksi internet ke router Mikrotik dari satu atau lebih ISP, dan Anda tidak suka dengan metode load-balancing, maka pilihan yang dapat anda gunakan yaitu menggunakan metode routing mark Mikrotik untuk memisahkan paket di semua Link ISP yang akan kita bahas. Routing Mark Mikrotik memungkinkan administrator jaringan untuk menandai paket berdasarkan atribut atau ip address yang telah ditentukan dan mengatur gateway. Dengan routing mark Mikrotik,
administrator jaringan dapat mengklasifikasikan paket ke dalam grup berdasarkan alamat IP address/ tujuan atau atribut lainnya dan mengatur gateway yang berbeda untuk setiap grup.

Dengan ini, pengguna yang cocok dengan kriteria yang ditetapkan untuk kelompok tertentu akan memiliki lalu lintas internet yang diarahkan keluar sambungan ISP melalui gateway yang ditetapkan untuk grup itu.

Tanda routing Mikrotik dapat diimplementasikan menggunakan fitur aturan mangle di sub-menu firewall di routerOS. Untuk menandai rute, Anda harus menandai User Connection, Packet dan routing. Routing Mark kemudian dipilih dan diberikan gateway di sub-menu rute.

IP address configuration

/ip address
add address=197.26.1.2/30 interface=ether1 comment=ISP1_INDIHOME
add address=41.12.8.2/30 interface=ether2 comment=ISP2_ASTINET
add address=62.6.14.2/30 interface=ether3 comment=ISP2_ASTINET
add address=192.168.10.1/24 interface=ether4 comment=LAN_LABKOM
add address=192.168.20.1/24 interface=ether5 comment=LAN_SI
add address=192.168.30.1/24 interface=ether6 comment=LAN_AKADEMIK

NAT Configuration

/IP firewall nat
add chain=srcnat out-interface=ether1 action=masquerade
add chain=srcnat out-interface=ether2 action=masquerade
add chain=srcnat out-interface=ether3 action=masquerade

Untuk menandai koneksi, paket dan routing untuk LAN_LABKOM masukkan perintah di bawah ini kedalam new terminal mikrotik. Perhatikan bahwa Routing MarkĀ digunakan untuk menandai paket dan pada packet mark yang digunakan untuk menandai rute.

Mikrotik routing mark configuration

Karena saya memiliki tiga LAN yang dikonfigurasi pada kasus ini, saya akan menggunakan mangle rule untuk menandai koneksi, paket, dan routing untuk masing-masing LAN; LABKOM, SI, dan AKADEMIK , dimulai dengan LABKOM yaitu sebagai berikut:

Routing mark untuk LABKOM

/ip firewall mangle
add chain=prerouting src-address=192.168.10.0/24 action=mark-connection new-connection-mark=labkom_conn
add chain=prerouting connection-mark=labkom_conn action=mark-packet new-packet-mark=labkom_packets
add chain=prerouting packet-mark=labkom_packets action=mark-routing new-routing-mark=labkom_route

Routing mark Untuk SI

/ip firewall mangle
add chain=prerouting src-address=192.168.20.0/24 action=mark-connection new-connection-mark=si_conn
add chain=prerouting connection-mark=si_conn action=mark-packet new-packet-mark=si_packets
add chain=prerouting packet-mark=HR_packets action=mark-routing new-routing-mark=si_route

Routing mark Untuk Akademik

/ip firewall mangle
add chain=prerouting src-address=192.168.30.0/24 action=mark-connection new-connection-mark=akademik_conn
add chain=prerouting connection-mark=finance_conn action=mark-packet new-packet-mark=akademik_packets
add chain=prerouting packet-mark=akademik_packets action=mark-routing new-routing-mark=akademik_route


Setelah menandai rute, kami akan menggunakan sub-menu rute untuk mengatur gateway yang berbeda untuk semua LAN kami. Lihat perintah di bawah ini.

Mengatur gateway untuk setiap LAN

/ip route
add dst-address=0.0.0.0/0 routing-mark=labkom_route gateway=197.26.1.1
add dst-address=0.0.0.0/0 routing-mark=si_route gateway=41.12.8.1
add dst-address=0.0.0.0/0 routing-mark=akademik_route gateway=62.6.14.1

Tambahkan sebuah Gateway Rules

/ip route rule 
add src-address=192.168.10.0/24 action=lookup table=labkom_route
add src-address=192.168.20.1/24 action=lookup table=si_route
add src-address=192.168.30.1/24 action=lookup table=akademik_route 

Untuk membaca lebih lanjut tentang aturan mangle, silakan klik di sini untuk membaca dokumentasi resmi mikrotik.

4 COMMENTS

  1. hai, salam kenal
    saya amat awam dan ingin belajar mengenai mikrotik lebih lanjut, lalu menemukan artikel ini.
    ad beberapa pertnyaan yg muncul setelah membaca2 artikel Anda, hehee…. kalau dengan setingan seperti ini, apakah pada posisi client harus di seting ip secara manual?? ataukah bisa dengan menggunakan DHCP Server?? apakah memungkinkan apabila Client yg statusny LABKOM, tanpa merubah posisi, hanya merubah IP lalu komputer Client tersebut akan berubah menjadi status client SI??

    terima kasih

    • salam kenal juga..
      Untuk setingan seperti ini memang di sisi client harus di seting ip secara manual karena tidak ditambahkan setingan untuk DHCP Server, mungkin kita bisa menambahkan setingan untuk dhcp server agar setiap client mendapatkan ip secara otomatis,hehe
      Untuk pertanyaan yg kedua sepertinya tidak memungkinkan karena sudah berbeda gateway

  2. mau tanya,
    1. apabila salah satu ISP mati/down. apakah client yang di arahkan ke ISP tersebut juga down akses Inet nya, ?
    2. Apakah antar client (labcom, SI dan akademik ) dapat saling terhubung.
    3. dalam kondisi ISP mati/down/slow mempengaruhi jaringan lokal ?

    terimakasih atas tanggapannya…

    • 1. Setingan disini apabila salah satu down, client jg internet akan down..karena bukan setingan failover
      2. Bisa karena hanya satu router mikrotik.
      3. Bisa berpengaruh karena disini bukan setingan load balancing

Leave a Reply