Menghubungkan beberapa kantor cabang ke kantor pusat dengan Mikrotik EOIP

0
370
eoip mikrotik
Menghubungkan beberapa kantor cabang ke kantor pusat dengan Mikrotik EOIP

Mikrotik eiop adalah protokol proprietary Mikrotik yaitu untuk membangun sebuah network tunel antara Mikrotik diatas sebuah koneksi TCP/IP. Sementara tidak banyak yang tahu tentang eiop hanya sedikit yang memahami dalam penerapannya. Pada artikel kali ini, kita akan membahas cara penggunaan eiop di hub dan topologi untuk menghubungkan beberapa kantor cabang ke kantor pusat.

Jika Anda adalah administrator jaringan, mengelola jaringan dengan banyak kantor cabang yang terhubung secara bersamaan melalui jaringan ISP, kemungkinan besar ISP Anda menggunakan Mikrotik eoip, Cisco dmvpn atau mpls untuk membuat link dengan kantor cabang Anda. Dalam kasus ini, kita akan menghubungkan tiga kantor cabang ke kantor pusat. Karena kita menggunakan antarmuka fisik, jumlah situs akan menjadi faktor penentu dalam memilih jenis router Mikrotik yang akan kita gunakan yaitu router mikrotik RB750.

Tujuan

Eoip bermanfaat untuk menghubungkan kantor cabang dengan kantor pusat. Diharapkan dapat membantu dalam file sharing dan interkoneksi antar kantor, mengurangi biaya operasional dan membantu meningkatkan produktivitas.

Implementasi EOIP Mikrotik.

Pada hub (Mikrotik RB750 yang melekat pada HQ), kita akan konfigurasi ether2 untuk menyediakan internet di HQ, ether3 akan menjadi koneksi layer2 ke branch1, ether4 akan menyediakan koneksi layer2 ke branch2, dan ether5 akan dikonfigurasi untuk menyediakan koneksi layer2 ke branch3 . Lihat perintah di bawah ini:

/ip address add address=201.2.2.1/30 interface=ether2 comment=internet_at_HQ
/ip route add dst=0.0.0.0 gateway=ether1

Selanjutnya, konfigurasi eoip Mikrotik di Hub.

Konfigurasi eoip Mikrotik pada hub untuk menghubungkan beberapa cabang

/interface eoip
add name=”eoip-to-branch1″ tunnel-id=10 remote-address=1.1.1.2
enable eoip-to-branch1
add name=”eoip-to-branch2″ tunnel-id=20 remote-address=2.2.2.2
enable eoip-to-branch2
add name=”eoip-to-branch3″ tunnel-id=30 remote-address=3.3.3.2
enable eoip-to-branch3

Selanjutnya, kita membuat bridge dan menambahkan interface eiop dan port yang sesuai pada RB750 ke setiap bridge. Lihat skrip di bawah.

/interface bridge
add name=bridge1
port add bridge=bridge1 interface=eoip-to-branch1
port add bridge=bridge1 interface=ether3
add name=bridge2
port add bridge=bridge1 interface=eoip-to-branch2
port add bridge=bridge1 interface=ether4
add name=bridge3
port add bridge=bridge1 interface=eoip-to-branch3

Selanjutnya adalah mengkonfigurasi jari-jari di semua cabang.

Konfigurasi EOIP pada Spoke 1

interface eoip
add name=”eoip-to-HQ” tunnel-id=10 remote-address=1.1.1.1
enable eoip-to-HQ
add name=bridge1
port add bridge=bridge1 interface=eoip-to-HQ
port add bridge=bridge1 interface=ether2

Konfigurasi EOIP pada Spoke 2

interface eoip
add name=”eoip-to-HQ” tunnel-id=20 remote-address=2.2.2.1
enable eoip-to-HQ
add name=bridge1
port add bridge=bridge1 interface=eoip-to-HQ
port add bridge=bridge1 interface=ether2

Konfigurasi EOIP pada Spoke 3

/interface eoip
add name=”eoip-to-HQ” tunnel-id=30 remote-address=3.3.3.1
enable eoip-to-HQ
add name=bridge1
port add bridge=bridge1 interface=eoip-to-HQ
port add bridge=bridge1 interface=ether2

Perhatikan bahwa pada router yang terhubung, ether1 dikonfigurasi untuk terhubung ke ISP cloud sementara ether2, yang ditunjukkan dalam konfigurasi digunakan untuk memberikan layanan layer2.

Akhirnya, kita tinggal konfigurasi router HQ untuk menyediakan konektivitas ke semua cabang melalui link pada layer2 yang dikirim oleh ISP. Empat kabel/port akan digunakan oleh ISP di kantor utama; satu untuk internet (layer3) dan tiga untuk konektivitas layer2 untuk menjadi cabang.

ip address 
add address=201.2.2.2/30 interface=ether1 comment=layer3-link
ip route add dst=0.0.0.0 gateway=ether1
ip firewall nat add out-interface=ether1 action=masquerade
ip add add address=192.168.1.1/24 interface=ether2 comment=HQ_LAN
ip add add address=192.168.2.1/24 interface=ether3 comment=Branch1_LAN
ip add add address=192.168.3.1/24 interface=ether4 comment=Branch2_LAN
ip add add address=192.168.4.1/24 interface=ether5 comment=Branch3_LAN

Kita juga akan konfigurasi server dhcp di HQ untuk menyediakan alamat IP untuk host pada HQ LAN dan yang terhubung ke switch di semua cabang.

Konfigurasi DHCP pada router HQ

Pada tahap ini, KIta akan konfigurasi empat server dhcp untuk menangani alamat IP leasing untuk HQ_LAN dan semua jaringan kantor brach. Lihat di bawah.

/dhcp-server
setup
Select interface to run DHCP server on
dhcp server interface: ether2

Pilih jaringan untuk alamat DHCP

dhcp address space: 192.168.1.0/24

Pilih gateway untuk jaringan yang diberikan

gateway for dhcp network: 192.168.1.1

Pilih kumpulan alamat ip yang diberikan oleh server DHCP
addresses to give out: 192.168.1.2-192.168.1.254

Select DNS servers

dns servers: 192.168.1.1
Select lease time
lease time: 3d
ip dhcp-server>

Ulangi langkah-langkah diatas untuk kantor cabang.

Jika artikel ini bermanfaat silahkan share atau berlangganan ke blog ini untuk menerima postingan terbaru yang akan di kirim melalui email dan apabila ingin disebarluaskan harap mencantumkan link sumbernya. Terimakasih

 

Leave a Reply