Ketika ada user hotspot yang mencoba login dan menampilkan pesan error maka user bisa langsung menghubungi admin dengan mengklik link menuju chat Whatsapp yang ditampilkan di halaman login hotspot, chat Whatsapp yang dikirimkan berisi informasi berupa IP Address, MAC Address dan keterangan error yang muncul.

Dengan begitu admin jaringan bisa mengatasi troubleshooting yang terjadi dengan informasi error yang muncul. Untuk melihat error ketika user hotspot login bisa juga di lihat di log pada mikrotik.

Pesan error login hotspot

Pesan error ini berada di folder dimana halaman hotspot disimpan dengan nama file error.txt, kita juga bisa mengganti sesuai dengan keinginan.

internal-error = internal error ($(error-orig))
config-error = configuration error ($(error-orig))
not-logged-in = you are not logged in (ip $(ip))
ippool-empty = cannot assign ip address - no more free addresses from pool
shutting-down = hotspot service is shutting down
user-session-limit = no more sessions are allowed for user $(username)
license-session-limit = session limit reached ($(error-orig))
wrong-mac-username = invalid username ($(username)): this MAC address is not yours
chap-missing = web browser did not send challenge response (try again, enable JavaScript)
invalid-username = invalid username or password
invalid-mac = user $(username) is not allowed to log in from this MAC address
uptime-limit = user $(username) has reached uptime limit
traffic-limit = user $(username) has reached traffic limit
radius-timeout = RADIUS server is not responding
auth-in-progress = already authorizing, retry later
radius-reply = $(error-orig)

Pesan error login hotspot setelah di edit

Saya mengedit file error.txt yang mudah dipahami oleh user hotspot kita, kira-kira error yang akan ditampilkan seperti ini:

internal-error = Mohon maaf hotspot sedang gangguan, silahkan hubungi admin ($(error-orig))
config-error = Mohon maaf ada kesalahan configurasi, silahkan hubungi admin : ($(error-orig)) 
not-logged-in = Anda belum login, silahkan coba lagi (ip $(ip))
ippool-empty = Tidak bisa memberikan IP Address, silahkan hubungi admin
shutting-down = Koneksi internet sedang gangguan, silahkan hubungi admin
user-session-limit = User $(username) sedang dipakai
license-session-limit = Masa aktif anda habis ($(error-orig))
wrong-mac-username = Username ($(username)): Bukan MAC Address yang terdaftar
chap-missing = Browser ini tidak merespon, coba aktifkan Javascrip, atau hubungi admin
invalid-username = User ($(username)) password salah, atau password sudah di ganti menjadi tanggal lahir contoh 7 Agustus 1999 (07081999)
invalid-mac = User $(username) silahkan login di MAC address yang terdaftar !
uptime-limit = User $(username) masa aktif habis
traffic-limit = User $(username) kuota habis
radius-timeout = RADIUS server tidak merespon, silahkan coba lagi, atau hubungi admin
auth-in-progress = Login gagal, silahkan coba lagi, atau hubungi admin
Station-Id = User $(username) hanya bisa di pake di MAC address yang terdaftar
radius-reply = $(error-orig)

Tambahkan kode html baris dibawah ini kedalam login hotspot

[php]Ada kesulitan ketika login? chat kami via Whatsapp <a href="https://api.whatsapp.com/send?phone=62NO-HP&text=IP: $(ip) MAC: $(mac) $(error), Mohon bantuanya..=">Klik Disini</a>
[/php]

Tempatkan di halaman logi page hotspot kira-kira seperti ini:

Ketika user hotspot menghubungi admin melalui halaman login akan mengirimkan chat ke Whatsapp kira-kira seperti dibawah ini:

Walled Garden Koneksi Whatsapp

Agar koneksi Whatsapp selalu terhubung walaupun belum login kita harus menambahkan pengecualian untuk koneksi Whatsapp dengan menambahkannya ke Walled Garden

/ip hotspot walled-garden
add dst-host=api.whatsapp.com dst-port=
add dst-host=wa.me dst-port=443
add dst-host=*.whatsapp.net dst-port=80
add dst-host=*.whatsapp.com dst-port=443
add dst-host=*.whatsapp.com dst-port=80
add dst-host=*.whatsapp.net dst-port=443

13 COMMENTS

  1. mantap bang,,alhamdulilah punya sy selain untuk pesan eror, sy manfaatin juga buat promo voucheran (baru mulai usaha vouheran) jadi yang ingin voucher gratis silahkan klik,, tapi yang jadi masalahnya hp user yang statusnya connect/tersambung (tapi blum login) bisa masuk ke WA tapi klw msih statusnya masuk ke jaringan gak bisa direct ke WA… mohon petunjuk

  2. kalau Walled Garden Koneksi LINE gimana ya Pak?

    saya tidak mau nomor WA saya tersebar, jadi saya pakai line, autodirect gt..
    keterangan LINE nya sudah saya sematkan di halaman login, tapi kondisi klo login error, klik LINE nya tidak bisa, mgkin karena tidak ada koneksi internet.

    itu pakai Walled Garden gitu bisa apa tidak ya?

Leave a Reply