halaman login mikbotam mikrotik
halaman login mikbotam mikrotik

Pada tutorial kali ini saya akan menujukan langkah-langkah agar MIKBOTAM di Localhost/webserver lokal bisa di akses dari luar jaringan dengan menggunakan subdomain. Pada tutorial yang berjudul Install MIKHMON dan MIKBOTAM di Localhost Bisa di Akses Online dengan Subdomain kita bisa menginstall dan mengonlinekan MIKHMON dan MIKBOTAM dalam satu komputer webserver.

Persiapan

Topologi

Inilah gambaran topologi yang saya gunakan

Langkah

Ganti file host

Buka fole host di C:\Windows\System32\drivers\etc\host, lalu tambahkan baris berikut:

127.0.0.1 localhost mikbotam.labkom.co.id

Modifikasi file httpd-vhosts.conf

Caranya buka folder dimana anda menginstall aplikasi Xampp C:\xampp\apache\conf\extra\httpd-vhosts.conf, hapus tanda # lalu modifikasi kira-kira menjadi seperti ini:


    ServerAdmin admin@labkom.co.id
    DocumentRoot "D:/xampp/htdocs/mikbotamphp"
    ServerName mikbotam.labkom.co.id
    ErrorLog "logs/mikbotam.labkom.co.id-error.log"
    CustomLog "logs/mikbotam.labkom.co.id-access.log" common

Dengan cara ini MIKBOTAM kita bisa dikenali dengan menggunakan subdomain yang sebelumnya apabila akan mengakses MIKBOTAM harus membuka alamat http://localhost/mikbotamphp. Setelah itu restart service apache anda.

Pada tahap ini seharusnya MIKBOTAM sudah bisa di akses dengan menggunakan subdomain di komputer yang terinstall webserver xampp.

Tambahkan Port Forwarding di Modem ZTE F609

Untuk menambahkan Port Forwarding di Modem ZTE F609 tambahkan dulu Application List seperti pada gambar dibawah ini, karena untuk mengakses MIKBOTAM menggunakan port http kita tambahkan ke Port Forwarding port 80

Tambahkan Lan Host IP Address dimana IP 192.168.1.2 merupakan IP Address Mikrotik yang terhubung langsung ke Modem.

Konfigurasi di MIKROTIK

Aktifkan dulu DDNS Mikrotik, lalu catatn ddns mikrotik anda.

/ip cloud set ddns-enabled=yes

Tambahkan NAT untuk Port Forwarding dan Redirect port DNS ke DNS nya Mikrotik. Tambahkan juga Address List untuk daftar IP Local.

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=80 in-interface=Eth1-indihome     protocol=tcp to-addresses=192.168.2.2 to-ports=80
add action=redirect chain=dstnat comment=dns dst-port=53 protocol=udp src-address-list=Local to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=tcp src-address-list=    Local to-ports=53

Tambahkan domain mikbotam.labkom.co.id ke dns static, seperti pada gambar dibawah ini.

Pada tahap ini seharusnya MIKBOTAM sudah bisa di akses dengan menggunakan DDNS Mikrotik dan bisa di akses pada jaringan lokal yang sama dengan menggunakan subdomain.

Konfigurasi di CPANEL

Agar kita bisa mengakses MIKBOTAM dengan menggunakan subdomain tambahkan cname baru seperti pada gambar dibawah ini:

Leave a Reply