Topologi Mikbotam dan mikhmon di xampp, di jaringan indihome
Topologi Mikbotam dan mikhmon di xampp, di jaringan indihome

Pada tutorial kali ini saya akan menujukan langkah-langkah agar MIKHMON dan MIKBOTAM di Localhost/webserver lokal bisa di akses dari luar jaringan dengan menggunakan subdomain (misalnya mikhmon.labkom.co.id).

(MIKHMON) MikroTik Hotspot Monitor adalah aplikasi berbasis web (MikroTik API PHP class) untuk membantu manajemen Hotspot MikroTik. Khususnya MikroTik yang tidak mendukung User Manager maka dari itu kita harus mengaktifkan terlebih dahulu api service mikrotiknya agar MIKHMON dan Mikrotik bisa saling terhubung dengan baik.
Mikhmon bukan radius server, jadi tidak harus selalu aktif. Mikhmon dapat diaktifkan saat dibutuhkan atau sesuai kebutuhan.

Persiapan

  • Internet
  • MIKHMON – Download di web resminya : https://laksa19.github.io/
  • Komputer webserver dan tentukan IP Servernya contoh: 192.168.2.2
  • Xampp – Download
  • Tentukan nama domain contoh : mikhmon.labkom.co.id dan mikbotam.labkom.co.id
  • Hosting dengan Cpanel

Topologi

Agar lebih memahami dalam konfigurasi di Mikrotik maupun di Modem inilah gambaran topologi yang saya gunakan, dimana dalam satu webserver terdapat dua aplikasi yang di onlinekan yaitu MIKHMON dan MIKBOTAM.

Pada tutorial yang berjudul Cara Install dan Konfigurasi MIKBOTAM di Localhost Xampp, menjelaskan langkah-langkah dalam instalasi dan konfigurasi MIKBOTAM, dibuat untuk memudahkan dalam pengaturan dan manajemen Mikrotik kita bisa membuat akun hotspot, generate voucher DLL dengan bantuan aplikasi seperti halnya MIKHMON. Atau anda hanya ingin menginstall aplikasi MIKBOTAM untuk managemen mikrotik bisa kunjungi tutorial berikut ini: MIKBOTAM di Localhost Bisa di Akses Online dengan Subdomain

Langkah

Setelah MIKHMON di download dengan nama folder “Mikhmon Server”, didalamya terdapat folder lagi dengan nama Mikhmon dan php, kita cukup memindahkan folder mikhmon ke folder C:\xampp\htdocs\

Buka fole host di C:\Windows\System32\drivers\etc\host, lalu tambahkan baris berikut:

127.0.0.1 localhost mikbotam.labkom.co.id mikhmon.labkom.co.id

Modifikasi file httpd-vhosts.conf

Caranya buka folder dimana anda menginstall aplikasi Xampp C:\xampp\apache\conf\extra\httpd-vhosts.conf

Dengan cara ini MIKHMON kita bisa diakses dengan menggunakan subdomain yang sebelumnya apabila akan mengakses MIKHMON harus membuka alamat http://localhost/mikhmon. Setelah itu restart service apache anda.

Akses MIKHMON menggunakan subdomin
halaman login mikbotam mikrotik
Akses MIKBOTAM menggunakan subdomain

Pada tahap ini seharusnya MIKHMON sudah bisa di akses dengan menggunakan subdomain di komputer yang terinstall webserver xampp.

Konfgurasi MIKHMON dengan MIKROTIK

Selanjutnya login dengan username “mikhmon” dan passwordn “1234”, akan muncul tampilan konfigurasi seperti berikut:

Setelah MIKHMON dan MIKROTIK berhasil terhubung.

Tambahkan Port Forwarding di Modem ZTE

Untuk menambahkan Port Forwarding di Modem ZTE F609 tambahkan dulu Application List seperti pada gambar dibawah ini, karena untuk mengakses MIKBOTAM menggunakan port http kita tambahkan ke Port Forwarding port 80

Tambahkan Lan Host IP Address dimana IP 192.168.1.2 merupakan IP Address Mikrotik yang terhubung langsung ke Modem.

Konfigurasi di MIKROTIK

Aktifkan dulu DDNS Mikrotik, lalu catatn ddns mikrotik anda.

/ip cloud set ddns-enabled=yes

Aktifkan API Service Mikrotik, pastikan Port API masih default yaitu 8728.

Pastikan tanggal dan jam sudah di set dengan benar dengan menambahkan SNTP Client.

/system ntp client
set enabled=yes primary-ntp=202.65.114.202 secondary-ntp=119.82.243.189

Tambahkan NAT untuk Port Forwarding 80 ke port web server 8080 dan Redirect port DNS ke DNS nya Mikrotik. Tambahkan juga Address List untuk daftar IP Local

/ip firewall nat
add action=redirect chain=dstnat dst-port=80 in-interface=pppoe-indihome protocol=tcp to-ports=8080
add action=redirect chain=dstnat comment=dns dst-port=53 protocol=udp src-address-list=Local to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=tcp src-address-list=   Local to-ports=53

Tambahkan domain mikhmon.labkom.co.id dan mikbotam.labkom.co.id ke dns static di Mikrotik, seperti pada gambar dibawah ini.

Akftifkan IP –> Web Proxy

Tambahkan Web Proxy Access untuk Mikhmon

Tambahkan juga Web Proxy access untuk Mikbotam

Block akses ke Web Proxy selain daftar host yang di ijinkan saja.

Pada tahap ini silahkan lakukan pengujian dengan mengakses MIKHMON dan MIKBOTAM dengan menggunakan domain pada komputer yang berbeda atau masih dalam satu jaringan yang sama.

Konfigurasi di CPANEL

Agar kita bisa mengakses MIKBOTAM dan MIKHMON dengan menggunakan subdomain tambahkan cname baru dengan name mikbotam.labkom.co.id dan mikhmon.labkom.co.id dengan recordnya yaitu DDNS Mikrotik anda, seperti pada gambar dibawah ini:

Kekurangannya, dengan menggunakan cara ini tidak support https/port 443 karena koneksi ke MIKBOTAM dan MIKHMON harus melewati Web Proxy Mikrotik terlebih dahulu itu artinya akses ke MIKBOTAM dan MIKHMON kurang aman karena aksesnya menggunkan http. Agar MIKBOTAM bisa di akses dengan menggunakan https kita bisa mencobanya menginstall di hosting anda bisa mencobanya pada postingan berikut ini Cara Install dan Konfigurasi MIKBOTAM ke Hosting.

Pada tutorial yang berjudul Cara Setting Mikrotik hAP Lite RB941-2ND untuk Voucher dengan Mikhmon dijelaskan langkah-langkah dalam membuat Hotspot Voucheran dengan menggunakan Mikrotik hAP Lite RB941-2ND.

Leave a Reply