Backup Otomatis Setingan Mikrotik Ke Server FTP Dengan Menggunakan Script dan Scheduler

0
279

Backup konfigurasi dapat digunakan untuk membuat cadangan konfigurasi MikroTik RouterOS ke file biner, yang dapat disimpan di router maupun dapat didownload dengan menggunakan FTP untuk digunakan kembali maupun di restore. Restore konfigurasi dapat digunakan untuk memulihkan konfigurasi router, sama halnya seperti pada saat membuat file backupan. Prosedur restorasi mengasumsikan kofigurasi direstore pada router yang sama, di mana file backupan awalnya dibuat bisa digunakan kembali apabila terjadi setingan Mikrotik yang salah maupun mengganti Router Board anda.

Langkah

Buatlah Scheduler baru dan tambahkan Script dibawah ini di kolom On Event, pada contoh kali ini saya akan membuat backupan setingan Mikrotik yang akan dikirimkan ke Server FTP selama satu minggu sekali.

:local identity [/system identity get name]
:local date [/system clock get date] 
:local time [/system clock get time]
:local day [ :pick $date 4 6 ]
:local month [ :pick $date 0 3 ]
:local year [ :pick $date 7 11 ]

:local months {"jan"="01";"feb"="02";"mar"="03";"apr"="04";"may"="05";"jun"="06";"jul"="07";"aug"="08";"sep"="09";"oct"="10";"nov"="11";"dec"="12"}
:local monthr {"jan";"feb";"mar";"apr";"may";"jun";"jul";"aug";"sep";"oct";"nov";"dec"}

:set month ($months->$month)
:set time ( [:pick $time 0 2].[:pick $time 3 5].[:pick $time 6 8] )

:local filename "$identity-$year$month$day-$time"
:put $filename


/system backup save name=$filename password=xxxxx
:delay 3s
/tool fetch mode=ftp port=21 password=(pasword ftp) keep-result=yes user=(user ftp) address=(Alamat FTP) upload=yes src-path="$filename.backup" dst-path="$filename.backup"
/file remove $filename

Sumber : Forum.Mikrotik.com

Referensi : wiki.mikrotik.com

Leave a Reply