Pada tutorial sebelumnya yang berjudul Membuat Halaman Pemberitahuan Ketika Internet Mati Untuk Pelanggan Hotspot telah dibahas cara membuat halaman pemberitahuan untuk pelanggan hotspot ketika terjadi gangguan internet down atau internet mati. Hanya saja untuk cara tersebut tidak bisa digunakan bagi pelanggan PPP atau PPPoE.

Jadi halaman maintanance ini bisa kita gunakan untuk semua Segmen IP, entah itu Client Hotspot maupun Client PPP/PPPoE atau Client LAN. Bagi teman-temang yang telah menggunakan Webproxy untuk halaman ISOLIR yang terdapat pada tutorial berikut Membuat Halaman ISOLIR untuk Pelanggan PPPoE Bulanan, tidak bisa menggunakan halaman Webproxy untuk digunakan sebagai halaman Maintanance, jadi harus menggunakan Webserver sebagai halaman maintanancenya. Kecuali Webproxy tidak digunakan kita bisa menggunakan Webproxy untuk halaman maintanancenya.

Untuk membuat halaman maintanance pada Webserver atau Localhost kita harus mempunyai Server atau PC yang terus menyala untuk menjalankan Webservernya, jadi hal ini memang menjadi kendala apabila harus menjalankan Server 24jam nonstop. Pada tutorial kali ini Saya akan coba membuat halaman maintanance di Webproxy dan Localhost, jadi teman-teman bisa memilih cara yang paling cocok untuk digunakan sebagai halaman maintanance.

Sebagai langkah awal kita buat dulu halaman maintanancenya sebagai contoh saya menggunakan halaman maintanance dari login page yang bisa di download disini , pada login page tersebut terdapat file Maintanance.html yang bisa kita edit dengan menggunakan Notepad atau Notepad++, atau dengan editor HTML yang lain seperti Dreamweaver.

Pada tahap ini anggap kita sudah memiliki halaman maintanance yang bisa diakses dengan menggunakan IP Address 192.168.5.2, catat IP ini yang nantinya akan kita gunakan untuk membuat rule di Mikrotik. Kemudian aktifkan Webproxy Mikrotik dengan cara ke menu IP–>Web Proxy. Catat Port yang digunakan yaitu 8080.

Tambahkan NAT untuk redirect semua IP Local ke Port WebProxy, pastikan semua IP Local (IP LAN, Hotspot dan PPPoE) sudah ditambahkan di Address List.

/ip firewall nat
add action=redirect chain=dstnat dst-address=!192.168.5.2 comment=MAINTANANCE disabled=yes dst-port=80,443 protocol=tcp src-address-list=Local to-ports=8080

Kemudian tambahkan Web Proxy Access, disini kita anggap ada halaman Isolir yang sudah dibuat pada tutorial sebelumnya. Lalu tambahkan semua Segmen IP kedalam Src Address, dengan action deny dan redirect ke IP 192.168.5.2 (Localhost).

/ip proxy access
add action=deny dst-address=!192.168.5.2 redirect-to=192.168.5.2 src-address=\
    192.168.2.0/24
add action=deny dst-address=!192.168.5.2 redirect-to=192.168.5.2 src-address=\
    192.168.4.0/24

Pada tahap ini kita sudah selesai membuat halaman Maintanance untuk semua segmen IP, tapi akan ada masalah apabila di Mikrotik tidak ada koneksi internet maka halaman login page tidak akan otomatis muncul, itu karena untuk menampilkan halaman login page terlebih dahulu Mikrotik akan mengecek ke DNS Server.

Ada trik untuk menampilkan halaman login page otomatis muncul ketika tidak ada koneksi internet yaitu dengan menambahkan DNS Static pada Mikrotik seperti pada gambar dibawah ini.

/ip dns static
add address=1.2.3.4 regexp=".*" comment="MAINTANANCE" ttl=00:00:10

Untuk IP DNS Diatas jangan memakai IP Mikrotik

Jangan lupa beri komentar “MAINTENANCE“, yang akan digunakan untuk enable dan disable otomatis dengan menggunakan Netwatch.

Kemudian buat sebuah Netwatch dengan host ke DNS Google, dan tambahkan script di On Down dan On Up.

Script On Up

/ip firewall nat disable [find comment=MAINTANANCE];
/ip dns static disable [find comment=MAINTANANCE];
/ip hotspot enable [find name=hotspot]

Pada script On Up akan menonaktifkan Rule di NAT dengan komentar “MAINTENANCE” dan menonaktifkan DNS Static dengan “MAINTENANCE

Script On Down

/ip firewall nat enable [find comment=MAINTANANCE];
/ip dns static enable [find comment=MAINTANANCE];
/ip hotspot disable [find name=hotspot]
/ppp active remove [find];

Pada script On Down sebaliknya, akan mengaktifkan rule tersebut dan menghapus/disconnect user PPP yang aktif.

Pada tahap ini kita telah selesai membuat Halaman Maintanance Internet Down untuk Pelanggan Hotspot dan PPP. Semoga tutorial ini bermanfaat, jangan lupa support terus Blog Labkom.co.id dan Chanel Labkom TV, agar saya tetap semanga membuat konten terbaru yang bermanfaat untuk kalian.