Pada tutorial kali ini saya akan menunjukan langkah-langkah agar ketika Mikrotik kita tidak ada akses ke internet maka halaman login akan berubah ke halaman pemberitahuan internet mati (halaman maintanance), ini bertujuan agar pengguna hotspot mengetahui kalau internet sedang gangguan. Hal ini cukup mudah kita bisa memanfaatkan Tool Netwatch yang terdapat pada Mikrotik.

Langkah

Buat halaman pemberitahuan maintanance dengan nama file login.html, contohnya seperti ini:

Lalu pindahkan ke file manager Mikrotik dan buat folder baru, jadi di file manager Mikrotik terdapat dua folder yaitu halaman untuk login hotspot dan folder halaman untuk maintanance.

Kita akan membuat pengaturan otomatis mengganti HTML Directory apabila internet mati akan berubah ke HTML Directory halaman maintanance.

Ketika internet up HTML Directory berubah menjadi halaman login
Ketika internet down HTML Directory berubah menjadi halaman maintanance

script ketika up:

/ip hotspot profile set html-directory=hotspot [find name=hotspot]

Script ketika down

/ip hotspot profile set html-directory=maintanance [find name=hotspot]

Tambahkan script ini di “on down” apabila ketika internet down semua device yang sedang online ter logout semua

/ip hotspot active remove [find]

Untuk memastikan bahwa internet benar-benar mati timeout diubah saja dengan angka yang lebih besar

Jadi dengan begitu ketika internet mati, maka untuk pelanggan hotspot akan ditampilkan halaman maintanance dan tidak bisa login. Apabila internet sudah up, HTML Directory akan berubah ke halaman login dengan begitu pelanggan hotspot bisa login kembali

Download Login Page dengan Halaman maintanance disini

Ada masalah ketika internet mati namun login page tidak otomatis muncul…! saya belum nemu solusinya hehe

Baca juga:

16 COMMENTS

  1. bang saya sudah coba untuk page maintanacenya di mikrotik saya kenapa tidak auto muncul ya page maintanace setelah internetnya down, jadi mesti manual buka browser baru bisa muncul page maintanacenya

  2. mau tanya mas ini bisa ngk untuk pelanggan rumahan menggunakan ip stastic untuk isolir juga untuk saat ada perbaikan di server

  3. supaya login page muncul saat internet down tambahkan DNS server pada segmen IP privat:
    IP > DHCP server > Networks > doble clik segmen ip dan tambahkan dns server 8.8.8.8, 8.8.4.4 > save

  4. oh iya lupa klo untuk user yg sudah aktiv/login harus dihapus dlu dri cookie dan tendang keluar(paksa logout) by script tambahkan di netwatch down

    :local dumplist [/ip hotspot active find]
    :foreach i in=$dumplist do={
    /ip hotspot active remove $i
    }
    :local dumplist [/ip hotspot cookie find]
    :foreach i in=$dumplist do={
    /ip hotspot cookie remove $i
    }

Leave a Reply