Install Aplikasi SISTER Kemenristekdikti di VirtualBox dan Bisa di Akses Publik

0
1782

Aplikasi Front End SISTER idealnya ditujukan untuk dipasang di masing-masing perguruan tinggi, kemudian untuk perguruan tinggi dibawah koordinasi Kopertis apabila belum memiliki infrastruktur yang memadai maka diharapkan untuk berkoordinasi dengan Kopertis Wilayah setempat. Dalam rangka menghindari permasalahan perbedaan data, dimohon untuk satu perguruan tinggi hanya memasang aplikasi Front End SISTER di satu server saja. Akses pengguna (dosen, tenaga pendidik dan administrator) nantinya akan melalui server yang sudah terpasang aplikasi Front End SISTER di masing-masing perguruan tinggi.

Sumber : Installer Aplikasi SISTER (Sistem Informasi Sumber Daya Terintegrasi)

Topologi Jaringan

Sebelum menginstal aplikasi SISTER anda harus memahami dahulu topologi jaringan yang anda gunakan, pada artikel kali ini saya menggunakan topologi pada gambar berikut:

Kebutuhan

Agar aplikasi SISTER berjalan dengan baik diperlukan perangkat keras (Hardware) dan Software pendukung diantaranya:

VirtualBox

Anda bisa mendownload aplikasi VirtualBox disini

Aplikasi SISTER untuk VirtualBox

Download aplikasi SISTER untuk VirtualBox https://goo.gl/fwUs8N 

Komputer server

Komputer server yang disarankan oleh DIKTI minimal menggunakan memory 12Gb, Hardisk 1TB dan Koneksi Internet 10 mbps dengan asumsi PTS tersebut mempunyai 200 orang dosen dengan aktifitas sedang.

Pada artikel kali ini saya menggunakan komputer dengan Spesifikasi Prosesor Core i3 Memory 4Gb dan hardisk 1TB denga asumsi kurang dari 30 orang dosen yang aktifitas sedang.

Sistem Operasi (OS)

Sistem Operasi yang disarankan oleh DIKTI diantaranya yaitu:

  • Windows Server 2012 64-Bit
  • Windows 10 64-Bit
  • Linux Ubuntu 14.04 64-Bit
  • Linux Ubuntu 16.04 64-Bit

Tahap Instalasi

Tambahkanlah sebuah Virtual Machine baru.

Pilihlah Virtual Hardisk aplikasi SISTER

Ubahlah pengaturan Network Adapter menjadi Bridged Adapter

Jalankan Aplikasi SISTER

Login aplikasi sister anda dengan menggunakan username admin_sister dan password admin_sister123. dan ketiklah perintah ifconfig. Lalu catatlah ip address tersebut.

Pengujian

Untuk menguji apakah aplikasi SISTER telah berjalan dengan baik, bukalah
IP Address tersebut di halaman browser anda. Apabila aplikasi SISTER bisa dipanggil dengan menggunakan IP Address anda bisa melanjutkan tahap selanjutnya.

Integrasi ke Jaringan Lokal

Agar IP Address aplikasi sister tidak berubah-ubah karena disini kita menggunakan DHCP Server buatlah IP Address SISTER tersebut menjadi static dengan cara IP –> DHCP Server –> Leases lalu pilih Make Static.

Tambahkan sebuah DNS Static

Agar IP Address SISTER anda bisa diakses dengan menggunakan Domain/Subdomain tambahkanlah sebuah DNS Static. Lihat pada gambar dibawah ini:

Baca juga : Monitoring Jaringan Mikrotik Menggunakan Bot Telegram Menggunakan Script dan Netwach

Paksa Client yang terhubung ke Mikrotik menggunakan DNSnya Mikrotik dengan cara Copy Paste Skrip berikut ke New Terminal

/ip firewall nat
add action=redirect chain=dstnat dst-port=53 protocol=udp to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=tcp to-ports=53

Tambahkan NAT

NAT disini berfungsi sebagai translasi IP Address privat ke IP address publik atau sebaliknya, sederhanaya koneksi dari luar jaringan Mikrotik anda akan di arahkan (redirect) ke IP Address private (IP lokal) anda. Ada dua cara yang bisa kita gunakan, yaitu dengan langsung redirect koneksi ke IP Server SISTER dan melalui Web Proxy Mikrotik.

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=80 protocol=tcp  to-addresses=192.168.5.126 in-interface=ether1-indihome to-ports=80

Selain menambahkan NAT seperti contoh diatas kita juga bisa mengunakan Web Proxy Mikrotik apabila dalam jaringan internal anda memiliki beberapa aplikasi yang akan di Online kan. Langkahnya yaitu, aktifkan dahulu IP –> Web Proxy.

Dan tambahkahkan sebuah NAT
/ip firewall nat
add action=redirect chain=dstnat dst-port=80 in-interface=ether1-indihome protocol=tcp to-ports=8080


Untuk mengaktifkan Web Proxy lihat pada gambar dibawah ini:

Tambahkan Web Proxy Access

Selain domain yang di daftarkan di Web Proxy Access, akan di tolak, simpan rule ini paling bawah

Buat Port Forwarding di Modem

Untuk membuat Port Forwarding di Modem ZTE F660 masuk ke halaman konfigurasi modem dengan IP 192.168.2.1 (Sesuaikan dengan IP modem anda) dengan akses sebagai admin.

Tambahkan Application List

Tambahkan Application List sesuai pada gambar dibawah ini:

Tambahkan LAN Host IP Address

Tambahkan IP Mikrotik anda di kolom LAN Host IP Address, dengan AppName yang telah dibuat tadi

Cek IP Public

Agar Mikrotik anda bisa di akses menggunakan IP Cloud / DDNS Mikrotik, IP yang didapat dari ISP harus bersifat Public bukan Private. Anda bisa mengeceknya dengan cara mencocokkan informasi IP Address di Modem dengan informasi IP Address yang di dapat dari whatismyip. Apabila IP Addressnya sesuai berarti IP Address tersebut bersifat Public, dan bisa di akses dari luar jaringan. Lihat gambar berikut ini:

IP Address di Modem ZTE F660
Informasi IP Address di whatismyip

Aktifkan DDNS/IP Cloud Mikrotik

Aktifkan DDNS/IP Cloud Mikrotik dengan menceklisnya, IP Address yang tertera di Public Address harus sesuai dengan IP Address yang tertera di modem dan whatismyip, apabila tidak sesuai anda bisa mengklik tombol Force Update sampai Public Address berubah. Anda juga bisa mengetikkan perintah di New Terminal

/ip cloud force-update

Sampai saat ini anda bisa mengakses Aplikasi SISTER anda dengan menggunakan alamat IP Cloud/DDNS Bawaan mikrotik

Tambahkan Scheduler/Penjadwalan

Agar ketika IP Public anda terjadi perubahan tambahkan sebuah Scheduler untuk mengaktifkan Force Update setiap 5 Menit sekali. Tambahkan di New Terminal

/system scheduler add interval=5m name=cloud_mikrotik on-event="/ip cloud force-update" start-time=startup

Menggunakan Custom Domain/Subdomain

Karena alamat IP Cloud/DDNS Bawaan mikrotik sangat sulit di ingat kita akan menggunakan custom domain sebagai alternatifnya.

Masuk ke Cpanel dan Tambahkan Zone Editor

Masuk ke Zone Editor lalu tambahkan sebuah CNAME Record, dan masukkan alamat IP Cloud/DDNS Mikrotik anda di kolom Record. Lihat gambar dibawah ini:

Sampai tahap ini seharusnya aplikasi SISTER sudah bisa di akses dari luar jaringan dengan menggunakan Sub Domain

Leave a Reply