EoIP Tunnel Topologi

Fungsi Tunnel EoIP MikroTik sangat populer di kalangan pengguna yang perlu memperluas jaringan Layer 2 antar situs. Ini dikonfigurasi seperti Tunnel GRE dan memperluas domain broadcast OSI Layer 2 antara situs. Setelah didirikan, Tunnel dapat dihubungkan ke adaptor fisik atau koneksi lainnya. Untuk aplikasi atau sistem lain yang membutuhkan adjacency Layer 2 ini adalah satu-satunya cara untuk membuatnya bekerja di seluruh situs, selain menggunakan sirkuit penyedia khusus atau tautan serat / microwave.

EoIP juga merupakan solusi untuk integrasi jaringan cepat dan kotor untuk dua situs yang memiliki subnet yang tumpang tindih yang, untuk alasan apa pun, tidak dapat sepenuhnya ditata. Usaha kecil dan kantor cabang sering memiliki jaringan datar dalam kisaran 192.168.0.0/24 atau 192.168.1.0/24, dan ketika mandat turun untuk memungkinkan komunikasi di antara mereka dengan cepat dan murah, EoIP adalah solusi yang memungkinkan. Akan perlu ada sedikit kompromi, dan aturan yang sama yang berlaku untuk satu jaringan di satu lokasi sekarang berlaku di seluruh lokasi. Dalam jangka panjang jaringan pembacaan untuk tidak tumpang tindih adalah ideal, tetapi untuk usaha kecil dengan anggaran TI terbatas dan sering kali tidak ada staf TI untuk berbicara tentang ini adalah solusi yang bekerja untuk jangka pendek.

Dalam situasi ini kami memiliki dua kantor kecil, satu di Router A dan yang lainnya di Router B. Kedua kantor memiliki LAN di subnet 192.168.1.0/24, dan pengguna harus dapat mengakses sumber daya di kedua kantor dari jarak jauh. Manajemen tidak memahami apa yang alamat jaringan lakukan atau mengapa itu penting, dan tugas ini harus dilakukan dengan gangguan minimal terhadap operasi yang sedang berlangsung.

Topologi Jaringan

Pertama kita akan membuat Tunnel EoIP, kemudian membuat bridges yang akan menghubungkan mereka ke LAN fisik, dan terakhir melakukan sedikit IP readdressing.

Buat Tunnel EoIP di router aktifkan enkripsi:

/interface eoip add comment="Router A" name="Router A" remote-address=2.2.2.2 tunnel-id=0 ipsec-secret=jfvowev8rg844bg0

Buat Tunnel EoIP di Router B dan aktifkan enkripsi:

/interface eoip add comment="Router B" name="Router B" remote-address=1.1.1.2 tunnel-id=0 ipsec-secret=jfvowev8rg844bg0

Nomor ID Tunnel harus cocok di setiap sisi. Selain itu, kunci IPSEC telah ditambahkan, yang akan mengenkripsi lalu lintas EoIP antara kedua situs. Ini adalah ide yang baik untuk diterapkan, tetapi ini merupakan langkah opsional tergantung pada kebutuhan keamanan Anda, dan ini hanya berfungsi di antara perangkat Mikrotik. Pada titik ini Anda akan melihat Tunnel muncul dan aktif, meskipun mungkin tidak ada lalu lintas yang melewatinya. Inilah Tunnel ke sisi Router B, seperti contohnya:

Anda mungkin telah memperhatikan bahwa Tunnel sedang berjalan (R) dalam mode slave (S) karena telah di bridges. Kami belum menyelesaikan langkah itu, tetapi kami akan mencapainya. Pertama, kita perlu menyelesaikan potensi konflik.

Awalnya kedua router memiliki gateway LAN mereka ditetapkan sebagai 192.168.1.1 – bukan masalah besar karena mereka terpisah. Namun, begitu kita di bridges dua LAN bersama itu menjadi masalah yang sangat besar, karena konflik IP akan mendatangkan malapetaka. Ini adalah salah satu kompromi yang disebutkan sebelumnya; sementara kami dapat memiliki dua lokasi berbagi subnet yang sama, kami tidak dapat memiliki alamat IP duplikat antara lokasi. Jadi di sisi Router B alamat IP gateway router telah diubah menjadi 192.168.1.128, yang tidak bertentangan dengan IP gateway Router A. Modifikasi alamat gateway perlu dibuat di sisi Router B untuk perangkat yang memiliki IP statis untuk mengakomodasi perubahan,

Di Router B ubah IP gateway LAN:

/ip address add address=192.168.1.128/24 interface=ether2

Langkah penting lain yang harus dilakukan adalah memisahkan lingkup DHCP di setiap sisi terowongan, sehingga server DHCP yang berjalan di router Mikrotik tidak membagikan alamat klien duplikat. Langkah ini unik untuk setiap organisasi dan cakupan DHCP yang mereka gunakan. Setelah itu selesai kita bisa beralih ke bridges antarmuka ke terowongan EoIP.

Ether2 adalah antarmuka LAN fisik kami di kedua router, dan kami harus mendapatkan lalu lintas dari antarmuka LAN fisik ke terowongan EoIP, lalu keluar dari terowongan dan ke LAN fisik di sisi lain – mudah dilakukan dengan bridges . Pertama kita akan membuat bridges , lalu menambahkan port ke sana.

Buat bridges di Router A dan tambahkan port:

/interface bridge add name="EoIP Bridge"
/interface bridge port
add bridge="EoIP Bridge" interface=ether2
add bridge="EoIP Bridge" interface="Router B"

Buat router di Router B dan tambahkan port:

/interface bridge add name="EoIP Bridge"
/interface bridge port
add bridge="EoIP Bridge" interface=ether2
add bridge="EoIP Bridge" interface="Router A"

Pada titik ini kita sudah selesai, hasil pengujian:

Ini dilakukan di lingkungan lab pada router virtual, dan grafik menunjukkan kecepatan yang konsisten di dua pengujian. Jumlah bandwidth itu mungkin cukup untuk menangani data antara dua kantor kecil, dan menggunakan Mikrotik Router yang lebih besar akan memungkinkan untuk kecepatan yang lebih tinggi. Namun perlu dicatat bahwa solusi khusus ini tidak dapat diskalakan untuk jaringan datar yang lebih besar, dan mendorong volume lalu lintas yang tinggi secara konsisten membebani CPU. Selain itu, kecepatan keseluruhan melintasi terowongan EoIP terbatas pada kecepatan koneksi WAN paling lambat, sehingga beberapa pengujian akan diperlukan untuk melihat apakah kinerja keseluruhan dapat diterima di lingkungan Anda.

Sumber : https://www.manitonetworks.com

Leave a Reply