Menjalankan Tunnel IP-IP antara situs dengan OSPF untuk perutean adalah site-to-site yang mudah dan dinamis. Kami akan menyiapkan Tunnel, mengkonfigurasi OSPF, dan memverifikasi konektivitas.

Topologi Jaringan

Topologi yang digunakan seperti pada gambar dibawah ini, dimana masing-masing site (kantor) menggunakan Router Mikrotik.

Kedua router terhubung ke internet dan memiliki alamat yang dapat dirutekan secara publik. Jaringan LAN masing-masing tidak saling tumpang tindih, dan telah menyisihkan jaringan 10.255.0.0/30 untuk alamat IPIP point-to-point. Menggunakan jaringan 10.255.0.0/30 memastikan tidak akan tumpang tindih dengan site tambahan yang online.

IPIP Tunnel

Menyiapkan Tunnel IPIP cukup mudah – arahkan satu router ke router lainnya dan hanya itu.

Router A:

/interface ipip add name=Router_B remote-address=2.2.2.2 comment=Router B

Router B:

/interface ipip add name=Router_A remote-address=1.1.1.1 comment=Router A

Tambahkan alamat IP yang dapat dirutekan ke antarmuka Tunnel IPIP. Ini memberi OSPF sesuatu untuk dijalankan di antara kedua perangkat. Memiliki protokol routing dinamis yang berjalan berarti solusi ini dapat tumbuh di luar dua site.

Router A :

/ip address add interface=Router_B address=10.255.0.1/30 comment="Router B link"

Router B:

/ip address add interface=Router_A address=10.255.0.2/30 comment="Router A link"

Routing OSPF

Kami akan menggunakan konfigurasi OSPF yang sangat sederhana karena hanya ada dua site. Kedua site akan diletakkan di area “Backbone” OSPF, angka nol. Seiring pertumbuhan jaringan, Anda dapat menambahkan area OSPF tambahan.

Router A:

/routing ospf network
add comment="Router B link" network=10.255.0.0/30
add comment="LAN" network=192.168.1.0/24

Router B:

/routing ospf network
add comment="Router A link" network=10.255.0.0/30
add comment="LAN" network=10.1.0.0/24

Konfigurasi ini memiliki OSPF link point-to-point antara router, dan LAN di belakang router. 

Sumber : https://www.manitonetworks.com