Home Mikrotik Konfigurasi Fail Over 3 WAN

Konfigurasi Fail Over 3 WAN

T opologi Fail Over 3 WAN
T opologi Fail Over 3 WAN

Konfigurasi Fail Over bertujuan agar koneksi internet selalu online apabila terjadi down di salah satu isp maka koneksi internet akan di alihkan ke isp yang dijadikan backup/cadangan.

Topologi

T opologi Fail Over 3 WAN
Topologi Fail Over 3 WAN
# ip modem1 = 172.16.1.1 ---> ether1
# ip modem2 = 172.16.2.1 ---> ether2
# ip modem3 = 172.16.3.1 ---> ether3
 
/ip route
add check-gateway=ping comment=exit-1 distance=1 gateway=172.16.1.1 routing-mark=exit-1
add check-gateway=ping comment=exit-2 distance=1 gateway=172.16.2.1 routing-mark=exit-2
add check-gateway=ping comment=exit-3 distance=1 gateway=172.16.3.1 routing-mark=exit-3
 
add check-gateway=ping comment=jalur-1 distance=1 gateway=172.16.1.1 routing-mark=jalur-1
add check-gateway=ping comment=jalur-1 distance=2 gateway=172.16.2.1 routing-mark=jalur-1
add check-gateway=ping comment=jalur-1 distance=3 gateway=172.16.3.1 routing-mark=jalur-1
 
add check-gateway=ping comment=jalur-2 distance=1 gateway=172.16.2.1 routing-mark=jalur-2
add check-gateway=ping comment=jalur-2 distance=2 gateway=172.16.3.1 routing-mark=jalur-2
add check-gateway=ping comment=jalur-2 distance=3 gateway=172.16.1.1 routing-mark=jalur-2
 
add check-gateway=ping comment=jalur-3 distance=1 gateway=172.16.3.1 routing-mark=jalur-3
add check-gateway=ping comment=jalur-3 distance=2 gateway=172.16.2.1 routing-mark=jalur-3
add check-gateway=ping comment=jalur-3 distance=3 gateway=172.16.1.1 routing-mark=jalur-3
 
add check-gateway=ping comment=jalur-1 distance=1 gateway=172.16.1.1
add check-gateway=ping comment=jalur-2 distance=2 gateway=172.16.2.1
add check-gateway=ping comment=jalur-3 distance=3 gateway=172.16.3.1

Buat system schedule dengan nama “fail-over” interval=00:00:10 dan tambahkan pada on event script dibawah ini :

#jalur-1 cek
:if ([/ping address=8.8.8.8 interface=ether1 routing=exit-1 count=5] = 0) do={/ip route set [find comment=jalur-1 gateway=172.16.1.1 distance=1] distance=4} else={/ip route set [find comment=jalur-1 gateway=172.16.1.1 distance=4] distance=1};
 
#jalur-2 cek
:if ([/ping address=8.8.8.8 interface=ether2 routing=exit-2 count=5] = 0) do={/ip route set [find comment=jalur-2 gateway=172.16.2.1 distance=1] distance=4} else={/ip route set [find comment=jalur-2 gateway=172.16.2.1 distance=4] distance=1};
 
#jalur-3 cek
:if ([/ping address=8.8.8.8 interface=ether3 routing=exit-3 count=5] = 0) do={/ip route set [find comment=jalur-3 gateway=172.16.3.1 distance=1] distance=4} else={/ip route set [find comment=jalur-3 gateway=172.16.3.1 distance=4] distance=1};

https://wiki.mikrotik.com/wiki/Failover_Scripting

https://wiki.mikrotik.com/wiki/Advanced_Routing_Failover_without_Scripting

1 COMMENT

  1. Master mau tnya, brarti sblum buat konfigurasi diatas kita harus bikin routing mark dlu ya untuk exit 1, 2, 3 dan jalur 1,2,3 ? Caranya bagaimana ? Apa cuma prerouting doang trus actionnya mark routing sperti itu ?

    Terimakasih

Leave a Reply

Kirim
Baca ketentuan kirim pesan VIA Whatsapp?
Ada pertanyaan seputar tutorial di blog ini?

Silahkan tanyakan melalui kolom komentar dibawah artikel atau melalui video di chanel Labkom TV.

KECUALI..!

1. Ngajak kerjasama
2. Butuh jasa setting
3. Konsultasi (berbayar)