script mikrotik scheduler
script mikrotik scheduler

Untuk merubah kecepatan internet user hotspot otomatis untuk siang dan malam kita harus memastikan terlebih dahulu jam dan tanggal di mikrotik berjalan dengan benar dengan mengatur konfigurasi SNTP Client di Mikrotik.

Konfigurasi SNTP Client di Mikrotik

/system ntp client
set enabled=yes primary-ntp=202.65.114.202 secondary-ntp=119.82.243.189
Konfigurasi SNTP Client pada Mikrotik

Buat Schedule untuk Siang

Buat schedule untuk menjalankan script untuk mengganti rate-limit pada user profil, atur schedule tersebut berjalan dengan interval 1d dengan start time pukul 07:00

Ketika ada user hotspot yang sedang aktif pada pukul 07:00 akan terlogout sendiri dan harus login ulang.

/ip hotspot host remove [find]
/ip hotspot user profile set "Tamu" rate-limit=512k/1M
/ip hotspot user profile set "Dosen" rate-limit=1m/5m
/ip hotspot user profile set "Mahasiswa" rate-limit=512k/3m
/ip hotspot user profile set "Pimpinan" rate-limit=1m/10m
/ip hotspot user profile set "admin" rate-limit=1m/5m
/ip hotspot user profile set "prodi" rate-limit=1m/3m
/ip hotspot user profile set "staf" rate-limit=1m/5m

Buat schedule untuk Malam

Buat schedule untuk menjalankan script untuk mengganti rate-limit pada user profil, atur schedule tersebut berjalan dengan interval 1d dengan start time pukul 16:00

Ketika ada user hotspot yang sedang aktif pada pukul 16:00 akan terlogout sendiri dan harus login ulang.

Leave a Reply