Anda bisa membuat, menghapus, disable, enable dan merubah profile user ppp/pptp Mikrotik dan menampilkan user ppp yang aktif hanya dengan bantuan bot telegram cukup dengan menggunakan System Script dan System Scheduler pada mikrotik tanpa harus punya server PHP sendiri, ini cukup mudah dipasang dan digunakan bagi orang awam yang tidak paham pemograman PHP. Tutorial ini update dari postingan sebelumnya yang berjudul Membuat User PPP/PPTP Dengan Menggunakan Bot Telegram.

Agar script ini berjalan dengan semestinya anda harus membuat terlebih dahulu bot telegram interaktif yang terdapat pada postingan berikut ini: Monitoring Mikrotik dengan Bot Telegram Interaktif tanpa Pemograman PHP

Perintah Pada Bot Telegram

Membuat User PPP

/ppp (spasi) Nama User PPP (spasi) Password (spasi) Nama Profile

Menghapus User PPP

/ppp (spasi) delete (spasi) Nama User PPP

Disable User PPP

/ppp (spasi) disable (spasi) Nama User PPP

Enable User PPP

/ppp (spasi) enable (spasi) Nama User PPP

Ganti Password User PPP

/ppp (spasi) password (spasi) Nama User PPP (spasi) Password baru

Ganti Profile User PPP

/ppp (spasi) profile (spasi) Nama User PPP (spasi) Nama Profile Baru

Menampilkan User PPP yang Aktif

/ppp (spasi) print

Script

Buat script dengan nama tg_cmd_ppp. Script ini akan dipanggil dengan perintah /ppp pada Bot Telegram.

Share to Unlock Contentimage/svg+xml

Silahkan share untuk membuka link download dan membuka scriptnya

Apabila tutorial ini bermanfaat support saya dengan cara share artikel ini.. Terimakasih 

18 COMMENTS

  1. Kl mau menambah perintah untuk mengetahu jumlah user yg online aja gimana ya pak? Kl yg /ppp print kan menampilkan semua nama yg online

      • kok ndak bisa ya pak ?

        apa saya ada yang kurang ?

        :local send [:parse [/system script get tg_sendMessage source]]
        :local ppp [:len [/PPP active connections find]]

        :put $params
        :put $chatid
        :put $from

        :local text “Router Id:* $[/system identity get name] * %0A\
        PPPoE users: _$ppp online_”

        $send chat=$chatid text=$text mode=”Markdown”
        :return true

  2. kalau untuk menhapus user ppp yang aktif gimana ya pak, tanpa menghapus yang ada di secret, kalau rumus ini (/ppp (spasi) delete (spasi) Nama User PPP) menghapus yang di secret ya pak

    • Cobntoh seperti ini, ini berdasarkan nama user

      :if ($param1=”deleteActive”) do={
      /ppp active remove [find name=$param2]
      $send chat=$chatid text=(“User Active: $param2 Berhasil dihapus”) mode=”Markdown”
      }

      ini contoh menghapus semua ppp active

      :if ($params=”deleteActiveAll”) do={
      /ppp active remove [find]
      $send chat=$chatid text=(“User Active Berhasil dihapus”) mode=”Markdown”
      }

  3. saya mau membuat seperti ini pak, NAMA (abcd) PASSWORD (abcd) SERVICENYA (ANY) {kalau di script ini kan SERVICENYA (PPTP} Profile (abcd) Kemudian saya juga inigin Membuat LOCAL ADDRESS (saya tulis manual CONTOH : 192.168.50.1) Remote Adrress (saya tulis manual CONTOH : 192.168.50.30) lewat bot telegram juga, apakah bapak bisa bantu untuk scriptnya, terimakasih pak sebelumnya

  4. pak mau tanya, untuk menampilkan nama user yang tidak ada di active connection gimana ya? jadi misalkan di pppoe secret ada nama A,B,C,D,E,F,G,H, kemudian beberapa user ini disconnect tanpa menghapus nama di secret (modem dimatikan, salah ganti password dial up / yang lain),.. dan saya ingin print berapa user yang disconnect tersebut..terima kasih

  5. saya ingin buat perintah
    ip firewall nat enable numbers=16 dan ip firewall nat disable numbers=16

    jadi jika saya ketik disable, maka nat pada baris ke 16 langsung ter disable. begitu sebaliknya gan.
    mohon pencerahannya gan..

  6. failure: closing connection: 149.154.167.220:443 (5)

    kira kira eror seperti itu ketika di masukan perintah print kenapa ya

  7. Malam mas Yayan,..
    Saya igin menampilkan semua nama user pppoe di mikrotik dengan script telegram, tetapi dengan keterbatasan pemahaman, saya belum bisa menampilkan,..
    mohon pencerahannya.
    Terimakasih atas waktunya & di tunggu kabar baiknya,
    semoga Tuhan membalas dengan Keberkahan.

Leave a Reply to Robyk Cancel reply