Home Mikrotik Monitoring Client PPTP/PPPoE/l2tp/sstp/ovpn Ketika Login dan Logout

Monitoring Client PPTP/PPPoE/l2tp/sstp/ovpn Ketika Login dan Logout

Pada tutorial kali ini saya akan membahas bagaimana caranya untuk Memonitoring dengan menggunakan telegram user PPP ketika login dan logout menggunakan script. Contoh penggunaan user PPP diantaranya yaitu PPTP, PPPoE, l2tp, sstp dan ovpn. Script ini di masukkan pada /ppp profiles dan pilih lah profile yang akan di tambahkan script untuk di monitoring. Kita juga bisa memanagement user PPP dengan menggunakan bantuan Bot Telegram, seperti membuat user ppp, enable dan disable user ppp, menghapus user ppp, mengganti user profile, dan menampilkan informasi secara detail user ppp yang sedang aktif simak tutorialnya dengan judul : Membuat dan Mengatur User PPP/PPTP Mikrotik dengan Bot Telegram Tanpa PHP. Mikrotik OS yang saya gunakan yaitu versi v6.45.3

Share to Unlock Contentimage/svg+xml

Silahkan share untuk membuka link download dan membuka scriptnya

Apabila tutorial ini bermanfaat support saya dengan cara share artikel ini.. Terimakasih 

UPDATE JANUARI 2021

Ada perbedaan di script untuk routerOS Versi 6.48 (stable) dimana ada penambahan Last Caller ID dan Last Disconnect Reason, jadi kita bisa menggunakan script dibawah ini

Script ON Login

:local nama "$user";
:local bot "954408780:BOTID";
:local chat CHAT ID";
:local service [/ppp secret get [find name=$nama] service];
:local local [/ppp secret get [find name=$nama] local];
:local remote [/ppp secret get [find name=$nama] remote];
:local profile [/ppp secret get [find name=$nama] profile];
:local last [/ppp secret get [find name=$nama] last-logged-out];
:local lastcall [/ppp secret get [find name=$nama] last-caller-id];
:local lastdic [/ppp secret get [find name=$nama] last-disconnect-reason];
/tool fetch url="https://api.telegram.org/bot$bot/sendMessage?chat_id=$chat&text=\E2\9C\85 LOGIN%0AUser: $user%0AService: $service %0ALocal Address: $local%0ARemote Address: $remote%0AProfile: $profile%0ALast Logout: $last%0ALast Caller ID: $lastcall %0ALast Disconnect Reason: $lastdic" mode=http keep-result=no;
PPPoE Monitoring ROS Versi 6.48 (stable)
PPPoE Monitoring ROS Versi 6.48 (stable)

Script ON LOGOUT

:local nama "$user";
:local bot "954408780:BOTID";
:local chat CHAT ID";
:local service [/ppp secret get [find name=$nama] service];
:local local [/ppp secret get [find name=$nama] local];
:local remote [/ppp secret get [find name=$nama] remote];
:local profile [/ppp secret get [find name=$nama] profile];
:local last [/ppp secret get [find name=$nama] last-logged-out];
:local lastcall [/ppp secret get [find name=$nama] last-caller-id];
:local lastdic [/ppp secret get [find name=$nama] last-disconnect-reason];
/tool fetch url="https://api.telegram.org/bot$bot/sendMessage?chat_id=$chat&text=\E2\9D\8C LOGOUT%0AUser: $user%0AService: $service %0ALocal Address: $local%0ARemote Address: $remote%0AProfile: $profile%0ALast Logout: $last%0ALast Caller ID: $lastcall %0ALast Disconnect Reason: $lastdic" mode=http keep-result=no;

Update Februari 2021

#SCRIPT LOGIN LOGOUT BY LABKOM.CO.ID
:local nama "$user";
:local bot "BOT ID";
:local chat "CHAT ID";
:local ips [/ppp active get [find name=$nama] address];
:local up [/ppp active get [find name=$nama] uptime];
:local caller [/ppp active get [find name=$nama] caller-id];
:local service [/ppp active get [find name=$nama] service];
:local active [/ppp active print count];
:local datetime "Tanggal: $[/system clock get date] %0AJam: $[/system clock get time]";
:local lastdisc [/ppp secret get [find name=$user] last-disconnect-reason];
:local lastlogout [/ppp secret get [find name=$user] last-logged-out];
:local lastcall [/ppp secret get [find name=$user] last-caller-id];
/tool fetch url="https://api.telegram.org/bot$bot/sendMessage?chat_id=$chat &text=\E2\9C\85 PPPoE LOGIN%0A$datetime%0AUser: $user%0AIP Client: $ips%0ACaller ID: $caller%0AUptime: $up%0ATotal Active: $active Client%0AService: $service%0ALast Disconnect Reason: $lastdisc %0ALast Logout: $lastlogout %0ALast Caller ID: $lastcall" mode=http keep-result=no;
#SCRIPT LOGOUT BY LABKOM.CO.ID
:local bot "BOT ID"; :local chat "CHAT ID"; :local lastdisc [/ppp secret get [find name=$user] last-disconnect-reason]; :local lastlogout [/ppp secret get [find name=$user] last-logged-out]; :local lastcall [/ppp secret get [find name=$user] last-caller-id]; :local active [/ppp active print count]; :local datetime "Tanggal: $[/system clock get date] %0AJam: $[/system clock get time]"; /tool fetch url="https://api.telegram.org/bot$bot/sendmessage\?chat_id=$chat&text=\E2\9D\8CPPPOE-LOGOUT %0A$datetime%0AUSER: $user%0ALast Disconnect Reason: $lastdisc %0ALast Logout: $lastlogout %0ALast Caller ID: $lastcall %0ATotal active: $active Client" keep-result=no;

24 COMMENTS

  1. tadi sempat muncul sekali untuk logout, tapi setelah itu ga muncul lagi. semua atribut address, uptime, dll tidak mau kecuali hanya ppp active print saja. mohon bantuannya om

  2. apa karena sudah terlanjur menghilang dari ppp active ya om? bisa di bantu ga om gmn supaya bisa. soalnya tadi sempat bisa sekali. setelah itu ga bisa lagi

  3. Hi i put the script in ON UP and in ON DOWN and if execute the script manualy it works fine but if i log in throught opevn i did not receive nothing on telegram, can you give me a hand of where is mistake? must i put particular script on Scheduler?

  4. permisi mas, ini cuma script login / UP aja yang bisa, sedangkan yang logout / DOWN gak bisa,,
    saya ada 2 mikrotik dan 2 bot.. dimikrotik A saya coba script UP/DOWN nya berhasil, tapi ketika saya coba script dari mikrotik A ke mikrotik B ( Beda id bot telegram ) hanya script UP yang bisa, kendalanya dimana ya?

  5. pak mau tanya, utk script tersebut apakah bisa menampilkan nama2 yang online atau offline,,, utk sementara kan hanya menampilkan jumlahnya saja (online / offline), jadi kita tidak perlu lagi melihat / mencocokkan antara nama2 di secret dan nama2 di active connection satu per satu..

  6. maaf agak panjang, gak bisa kirim gambar soalnya..
    ini sebagai contoh saja (telegram) :
    ____________________________________

    Status: OFFLINE ❌
    User: Ahmad
    Service: pppoe
    IP Server: XX.XX.XX.XX
    IP ONT: XX.XX.XX.XX
    SN ONT: XX.XX.XX.XX.XX
    Total Client: 10 Client
    Total Active: 9 Client
    Offline Client:
    – Ahmad
    _____________________________________

    Status: OFFLINE ❌
    User: Basir
    Service: pppoe
    IP Server: XX.XX.XX.XX
    IP ONT: XX.XX.XX.XX
    SN ONT: XX.XX.XX.XX.XX
    Total Client: 10 Client
    Total Active: 8 Client
    Offline Client:
    – Ahmad
    – Basir
    ______________________________________

    Status: ONLINE ✔️
    User: Ahmad
    Service: pppoe
    IP Server: XX.XX.XX.XX
    IP ONT: XX.XX.XX.XX
    SN ONT: XX.XX.XX.XX.XX
    Total Client: 10 Client
    Total Active: 9 Client
    Offline Client:
    – Basir
    _______________________________________

    kurang lebih hasilnya seperti itu pak hehe 🙇🙇

Leave a Reply

Kirim
Baca ketentuan kirim pesan VIA Whatsapp?
Ada pertanyaan seputar tutorial di blog ini?

Silahkan tanyakan melalui kolom komentar dibawah artikel atau melalui video di chanel Labkom TV.

KECUALI..!

1. Ngajak kerjasama
2. Butuh jasa setting
3. Konsultasi (berbayar)