Pada tutorial kali ini kita bisa membuat user ppp pada Mikrotik dengan menggunakan Bot Telegram hanya dengan menggunakan script dan scheduler saja pada Mikrotik. Jadi tutorial ini dibuat untuk menjawab pertanyaan yang ada di video di chanel youtube saya.

Langkah

Untuk membuat user ppp dengan menggunakan Bot Telegram kita pastikan dulu kalian telah membuat Bot Telegram hanya dengan menggunakan Script dan Scheduler setidaknya fungsi /hi pada bot telah berjalan, untuk membuat Bot Telegram dengan menggunakan Script dan Schedule silahkan kunjungi postingan dengan judul: Monitoring Mikrotik dengan Bot Telegram Interaktif tanpa Pemograman PHP

Buat Script dengan nama tg_cmd_ppp

Script ini nantinya akan dipanggil dengan perintah /ppp. [signinlocker id=”2302″]

:local send [:parse [/system script get tg_sendMessage source]]
:local param1 [:pick $params 0 [:find $params " "]]
:local param2 [:pick $params ([:find $params " "]+1) [:len $params]]
:local param3 [:pick [:pick $params ([:find $params " "]+1) [:len $params]] ([:find [:pick $params ([:find $params " "]+1) [:len $params]] " "]+1) [:len [:pick $params ([:find $params " "]+1) [:len $params]]]]
:if ([:len [:find $param2 " "]]>0) do={
	:set param2 [:pick [:pick $params ([:find $params " "]+1) [:len $params]] 0 [:find [:pick $params ([:find $params " "]+1) [:len $params]] " "]]
} else={
	:set param3 ""
}

:put $params
:put $param1
:put $param2
:put $param3
:put $chatid
:put $from

/ppp secret add name=$param1 password=$param2 service=pptp profile=$param3 
$send chat=$chatid text=("User PPP %0AUsername: $param1 %0APassword: $param2 %0AProfile: $param3 %0ABerhasil dibuat...") mode="Markdown"

[/signinlocker]

Perintah pada bot:

/ppp <spasi> Nama User PPP <spasi> Password <spasi> Profile

Hasilnya

Baca juga : Membuat dan Mengatur User PPP/PPTP Mikrotik dengan Bot Telegram Tanpa PHP

Leave a Reply