Network Address Translation (NAT) merupakan sebuah sistem untuk menggabungkan lebih dari satu komputer untuk dihubungkan ke dalam jaringan internet hanya dengan menggunakan sebuah alamat IP. Sehingga setiap komputer di dalam NAT ketika berselancar di internet akan terlihat memiliki alamat IP yang sama jika dilacak. Dengan kata lain, sebuah alamat IP pada jaringan lokal akan terlebih dahulu ditranslasikan oleh NAT untuk dapat mengakses IP publik di jaringan komputer. Begitupun sebaliknya IP Lokal dapat di akses dengan menggunakan IP Publik dengan menggunakan NAT.

Sebagai contoh saya mempunyai Webserver Localhost dengan IP 30.30.30.30, localhost tersebut ingin diakses dengan menggunakan IP Cloud Mikrotik atau DDNS dari IP-Dynamic di ISP Indihome. Contoh rule untuk NAT IP Publik kira-kira seperti ini:

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=30.30.30.30 to-ports=80 protocol=tcp dst-address=IP Public dst-port=80

Rule diatas akan berfungsi ketika kita mengakses IP Public maka akan di teruskan/translasikan ke IP Lokal 30.30.30.30. Nah untuk menambahkan NAT untuk IP Publik yang selalu berubah-ubah kita akan menambahkan IP Publik ke address list dari IP Publik yang muncul DDNS Mikrotik / IP Cloud dengan menggunakan Script dan Scheduler.

Topologi

Gambaran Topologi kira-kira seperti ini, dimana kita akan mengakses Webserver Localhost 30.30.30.30 dengan menggunakan IP Publik/DDNS Mikrotik/DDNS IP Dynamic.

Langkah-Langkah

Buat Scheduler

Tambahkan script ini di on event, saya membuat interval 10 detik. Script ini akan bekerja setiap 10 detik sekali dan akan membuat address list baru dari IP Publik yang muncul di IP Cloud Mikrotik dengan nama public.

:local public;
:set public [/ip cloud get public-address];
/ip firewall address-list add address=$public list=public timeout=00:10:00

Buat NAT

Buat sebuah NAT untuk mentranslasikan IP Public dari address list ke IP Local 30.30.30.30.

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=30.30.30.30 to-ports=80 protocol=tcp dst-address-list=public dst-port=80

Leave a Reply