Bagi pelanggan ISP dengan IP Dinamis seperti Indihome mungkin sering menemukan Google Captcha kompilasi akan mencari sesuatu dengan mesin pencari Google, hal ini terkait IP Publik kita dianggap spam oleh google, bisa jadi karena IP Publik yang kita manfaatkan digunakan untuk spam .
Solusi
Untuk mengatasi hal tersebut, coba restar modem Anda sampai menemukan IP Publik yang dianggap bersih oleh google. Jika modem Anda sebagai bridge dan mikrotik yang mendial Anda dapat mencoba cara berikut ini:
Buat Script
Ketika ada klien, kompilasi penelusuran keluar captcha maka di dns cache akan muncul dns dengan nama ipv4.google.com. Script ini akan membahas dns cache yang dialokasikan 5 atau lebih dns dengan nama ipv4.google.com maka akan melakukan dial ulang pppoe out.
Silahkan share untuk membuka link download dan membuka scriptnya
Apabila tutorial ini bermanfaat support saya dengan cara share artikel ini..
Terimakasih
:global countSpam :global currentIP :global iface pppoe-indihome :if ([:len [/ip dns cache all find where name="ipv4.google.com" ]] = 1 ) do={ :set countSpam ($countSpam +1) :log error "Akses ke google kena spam" } :if (($countSpam >= 5) && ([:len [/ip dns cache all find where name="ipv4.google.com" ]] = 1 )) do={ :log error "generate ip baru" :set countSpam 0 /in pppoe-client enable $iface :delay 2; /ip dns cache flush :log warning "DNS Cache has cleaned!" :delay 2; :set $currentIP [/ip address get [find interface="$iface"] address] :for i from=( [:len $currentIP] - 1) to=0 step=-1 do={ :if ( [:pick $currentIP $i] = "/") do={ :set currentIP [:pick $currentIP 0 $i] } } :log warning $currentIP :local router [/system identity get name] :local time [/system clock get time] :local date [/system clock get date] :local voltage [/system health get voltage] :local tegangan (. [:pick $voltage 0 2] . "," . [:pick $voltage 2 3] ." volt") :local pesan ("[ $router ]%0A" ."GENERATE IP%0A$currentIP:81/userman%0AKENA SPAM pada : %0A" . $time .", ".$date. "%0AVoltase saat ini $tegangan.") /tool fetch url="https://api.telegram.org/bot552750641:AAGlWdQJkfAIOZzbyGXlbst6_NJXk-39CDU/sendMessage?chat_id=396413333&text=$pesan" keep-result=no }