dhcp server lease to simple queue script

Script ini bekerja ketika terdapat device yang terhubung ke DHCP Server lalu secara otomatis melimit dengan simple queue, dengan syarat device tersebut berstatus bound di DHCP Server–> Leases

Langkah

Masuk ke IP –> DHCP Server –> Pilih nama DHCP Server, lihat pada gambar berikut:

Setelah dipilih, Simpan script di kolom Leases Script, lihat pada gambar berikut:

Script DHCP Server Lease To Simple Queue

Ubah nama parent dan nama client apabila ingin diubah lalu Sesuaikan dengan IP Network dan total Bandwith yang akan di limit.

:local parent [/queue simple find name=HOTSPOT]
:local network "172.16.0.0/16"
:local queueName "HOTSPOT- $leaseActMAC";
:if ([:len $parent] = 0) do={/queue simple add name=HOTSPOT max-limit=5000k/800000k target="$network" packet-marks=no-mark}
:if ($leaseBound = "1") do={
/queue simple add name=$queueName target=($leaseActIP . "/32") max-limit=1000k/10000k burst-limit=3000k/10000k burst-time=8/8 parent=HOTSPOT;
} else={
/queue simple remove $queueName
}

Hasilnya

Semua Device yang terhubung dengan DHCP Server di limit otomatis dengan menggunakan Simple Queue. Ini sangat berguna bagi router Mikrotik yang melayani client yang cukup banyak jadi tidak repot dalam hal managemen bandwith. Script untuk memonitoring Client yang terhubung ke DHCP Server lalu akan otomatis di monitoring dengan Netwatch dengan judul : Monitoring Client DHCP Lease dengan Netwatch dan Bot Telegram.

Referensi: Forum Mikrotik

Leave a Reply