DHCP (Dynamic Host Configuration Protocol) digunakan untuk memudahkan pendistribusian alamat IP (IP Address) dalam suatu jaringan. Implementasi MikroTik RouterOS mencakup bagian server dan klien dan sesuai dengan RFC 2131.

Router Mikrotik mendukung server individual untuk setiap interface yang mirip Ethernet. DHCP Server Mikrotik mendukung fungsi dasar untuk melayani setiap klien yang meminta alamat IP / netmask, default gateway, nama domain, server DNS dan server WINS (untuk klien Windows).

Agar server DHCP berfungsi dengan baik, kolam IP Address juga harus dikonfigurasikan (jangan menyertakan alamat IP server DHCP sendiri ke dalam kisaran pool) dan jaringan DHCP.

Fungsi Script ini akan mengirimkan sebuah notifikasi melalui e-mail ketika perangkat yang terhubung melalui DHCP Server Mikrotik. Manual penggunaan DHCP Mikrotik

Masuk Ke menu IP-DHCP Server, lalu pilihkan nama DHCP Server yang akan ditambahkan sebuah Script.

:local hostname[/ip dhcp-server lease get [find where active-mac-address=$leaseActMAC && active-address=$leaseActIP] host-name]
:if ($leaseBound = "1") do={
/tool e-mail send to=admin@labkom.co.id subjec="$hostnameLogin"  body=("Login $hostname$leaseActMAC $leaseActIP".[/system clock get time]."") start-tls=yes 
} else={
/tool e-mail send to=admin@labkom.co.id subjec="$hostnameLogin"  body=("Logout $hostname$leaseActMAC $leaseActIP".[/system clock get time]."") start-tls=yes
}

Leave a Reply