Monitoring DHCP Server Mikrotik Menggunakan Bot Telegram

0
204

DHCP Server

Dynamic Host Configuration Protocol (DHCP) merupakan service yang memungkinkan perangkat dapat mendistribusikan/assign IP Address secara otomatis pada host dalam sebuah jaringan. Cara kerjanya, DHCP Server akan memberikan response terhadap request yang dikirimkan oleh DHCP Client. 

Selain IP Address, DHCP juga mampu mendistribusikan informasi netmask, Default gateway, Konfigurasi DNS dan NTP Server serta masih banyak lagi custom option (tergantung apakah DHCP client bisa support). 

Pada artikel kali ini kita akan memanfaatkan Bot Telegram untuk memonitoring DCHP Server pada mikrotik, setiap perangkat yang terhubung ke DHCP Server akan mengirimkan informasi Client yang terhubung ke Bot Telegram.

Untuk membuat Bot Telegram silahkan kunjungi artikel berikut ini : Membuat Bot Telegram

LANGKAH

Buat sebuah script dengan nama “SendToTelegram”, sesuaikan Bot dan chat id telegram anda.

:global telegramMessage
:local botid
:local chatid

set botid "bot"
set chatid "chat id" 

if ($telegramMessage != "") do={
   /tool fetch url="https://api.telegram.org/bot$botid/sendMessage\?chat_id=$chatid&text=$telegramMessage" keep-result=no
   set telegramMessage ""
}

Tambahkan sebuah script di DHCP-Server

if ($leaseBound = "1") do={
global telegramMessage "$"lease-hostname" ($leaseActMAC) got address $leaseActIP from DHCP_guest"
/system script run SendToTelegram
}

Sumber : Forum Mikrotik

Leave a Reply