ping-delay-mikrotik-ping

Script ini akan bekerja ketika trafik sedang penuh, ping membengkak atau terjadi delay, atur IP Address dan latency sesuai dengan keinginan anda.

Buat sebuah schedule dan simpan script ini di On Event

Script

#script labkom.co.id
:local addre 8.8.8.8;
#Set the delay
:local ms 19;
:local avgRtt;
/tool flood-ping $addre count=10 do={
  :if ($sent = 10) do={
    :set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#Kirim telegram
/tool fetch url="https://api.telegram.org/botXXXXXXXXXXXXXXXX/sendMessage?chat_id=XXXXXXXXXXXX&text=Monitoring IP:$addre delay:$avgRtt ms" keep-result=no;
}

Hasilnya

Monitoring ke IP 8.8.8.8 dengan minimal latency 18 ms
Monitoring ke IP 8.8.8.8 dengan minimal latency 200 ms

Referensi : Forum Mikrotik

Leave a Reply