Script Kirim Pesan ke Semua Pelanggan PPPoE dengan WA Gateway
Script Kirim Pesan ke Semua Pelanggan PPPoE dengan WA Gateway

Script ini dibuat untuk melengkapi tutorial di Chanel LabkomTV, silahkan cek cara penggunaanya di video dibawah ini

:local varDate;
:local varDay;
:set varDate [/system clock get date];
:set varDay [:pick $varDate 4 6];
:if ($varDay = "01") do={ 
#Script dibawah simpan disini
}
:local ppp value=[/ppp secret find];
:local pesan "Pelanggan Labkom yang terhormat";
:foreach secret in=$ppp do={
:local wa [/ppp secret get $secret value-name=comment];
/tool fetch http-header-field="content-type: application/x-www-form-urlencoded" http-method=post http-data="number=$wa&message=$pesan" url="http://linkwagateway/send-message" keep-result=no;
:log warning "Pesan terkirim ke $wa";
};
:log warning "Pesan berhasil terkirim semua";

Leave a Reply