Ketika kita mengakses website tertentu terkadang dialihkan dulu ke website Uzone.id, misalnya ketika mengakses website yang tidak terdaftar maka akan diarahkan ke website mercusuar.uzone.id. Juga ketika kita mengakses website yang terlarang maka akan diarakhan/redirect ke website internetpositif.uzone.id atau block.uzone.id. Kita bisa mengganti/redirect website dari Uzone.id menjadi website/blog yang kita inginkan di Mikrotik.

Konsepnya kita akan redirect IP Server dari semua domain uzone.id kemudian IP Server tersebut akan di redirect ke webserver, lalu di webserver akan di redirect lagi ke website/blog yang kita inginkan.

Langkah

Untuk mengganti halaman dari uzone.id caranya cukup mudah, kita cukup menyiapkan sebuah webserver lokal yang akan digunakan untuk meredirect ke website yang kita inginkan.

Insall Webserver Xampp

Install terlebih dahulu webserver xampp lalu edit index.php di folder C:/xampp/htdocs/index.php menjadi seperti ini:

Buat Schedule

Buat sebuah schedule untuk menjalankan script ini, dimana script ini fungsinya untuk menambahkan semua IP Server dari domain uzone.id kedalam Address List di Mikrotik.

:do {
:local LIST "uzone.id";
:local DOMAIN "uzone.id";
 :foreach Crec in=[/ip dns cache all find where ( ( (type="A") || (type="CNAME") ) && (static=no) && (name~$DOMAIN) )] do={
  :local Cname [/ip dns cache get number=$Crec name]; 
  :local Cdata "";  
  :delay 100ms;
  :if ([/ip dns cache all get $Crec type]="CNAME") do={ 
   :set $Cdata [:resolve $Cname]; } else={ 
   :set $Cdata [/ip dns cache get number=$Crec address]; } 
  :do {/ip firewall address-list
   :do {add list=$LIST address=$Cdata comment=$Cname disabled=no} on-error={:log warning message="address entry exist: List=$LIST , Host=$Cname , Address=$Cdata";}
  }
 } 
} on-error={:log error message="script failed..."}

Semua domain dari uzone.id akan dimasukkan kedalam Address Lists yang nantinya akan di redirect dengan menggunakan IP Firewall Nat di Mikrotik.

Buat Nat

Buat sebuah Nat untuk meredirect semua IP Publik dari domain Uzone.id ke IP Webserver yang telah kita install.

Hasilnya