Mikrotik Monitoring Traffic Counter berguna untuk menyimpan traffic upload dan download ke sebuah database lalu menampilkannya dalam sebuah grafik yang sederhana, dengan menggunakan script ini kita bisa memantau penggunaan kuota/FUP internet.

Kita bisa menampilkan traffic perjam, harian, mingguan dan bulanan, ini bermanfaat bagi kalian yang menggunakan ISP dengan sistem FUP agar penggunaan FUP bisa terpantau setiap saat.

Buat dulu sebuah mangle untuk menandai traffic upload dan download, jangan lupa tambahkan IP LOCAL anda ke address list dengan nama IP_LOCAL.

/ip firewall mangle
add action=passthrough chain=forward comment=local-wan-tx out-interface=\
    ether1 src-address-list=IP_LOCAL
add action=passthrough chain=forward comment=local-wan-rx dst-address-list=\
    IP_LOCAL in-interface=ether1

Kemudian buat sebuah schedule untuk mengirimkan informasi traffic upload dan download dari rule diatas ke webserver, webserver yang saya miliki memiliki IP 192.168.5.254, didalam folder monitor. Download script PHP

:local wantxcomment "local-wan-tx"
:local wanrxcomment "local-wan-rx"
:local sysnumber [/system identity get name] 
:local txbytes [/ip firewall mangle get [/ip firewall mangle find comment="$wantxcomment"] bytes]
:local rxbytes [/ip firewall mangle get [/ip firewall mangle find comment="$wanrxcomment"] bytes]
/tool fetch url=("http://192.168.5.254/monitor/collector.php\?sn=$sysnumber&tx=$txbytes&rx=$rxbytes") mode=http keep-result=no
/ip firewall mangle reset-counters [/ip firewall mangle find comment="$wantxcomment"]
/ip firewall mangle reset-counters [/ip firewall mangle find comment="$wanrxcomment"]
:log info ("cleared counters for all mangle rules")

 

Disini saya membuat schedule dengan interval 5 detik, ini artinya setiap 5 detik sekali schedule ini akan mengirimkan informasi upload dan download ke webserver anda.

Hasilnya kita bisa memantau penggunaan traffic download dan upload pada sebuah ethernet seperti pada gambar dibawah ini

Karena script php ini menggunakan database SQL Lite, secara default extension untuk sqlite nonaktif (webserver XAMPP) kita harus mengaktifkan terlebih dahulu dengan cara cari extension=php_pdo_sqlite.dl extension=php_pdo_sqlite.dl di file php.ini di folder C:\xampp\php dan dan hapus tanda “;”. Setelah itu restart service apache dan MySQL anda.

https://github.com/muhannad0/mikrotik-traffic-counter

4 COMMENTS

Leave a Reply