Anda dapat mengganti password SSID wireless mikrotik, mengganti nama SSID mikrotik dan menampilkan jumlah device yang terhubung ke wireless mikrotik hanya dengan bantuan bot telegram cukup dengan menggunakan System Script dan System Scheduler pada mikrotik tanpa harus punya server PHP sendiri, ini cukup mudah dipasang dan digunakan bagi orang awam yang tidak paham pemograman PHP.

Agar skrip ini berjalan dengan semestinya Anda harus membuat terlebih dahulu bot telegram interaktif yang ada pada postingan berikut ini: Memantau Mikrotik dengan Bot Telegram Interaktif tanpa Pemograman PHP

Perintah pada bot:

  • /wireless pasword namaSecurityProfiles passwordBaru –> Mengganti WPA Pre-shared key
  • /wireless ssid ssidLama ssidBaru –> Mengganti nama ssid pada wireless mikrotik
  • /wireless count –> Menampilkan total device yang terhubung ke wireless mikrotik

Buat Script dengan nama “tg_cmd_wireless”

:local send [:parse [/system script get tg_sendMessage source]]
:local param1 [:pick $params 0 [:find $params " "]]
:local param2 [:pick $params ([:find $params " "]+1) [:len $params]]
:local param3 [:pick [:pick $params ([:find $params " "]+1) [:len $params]] ([:find [:pick $params ([:find $params " "]+1) [:len $params]] " "]+1) [:len [:pick $params ([:find $params " "]+1) [:len $params]]]]
:if ([:len [:find $param2 " "]]>0) do={
	:set param2 [:pick [:pick $params ([:find $params " "]+1) [:len $params]] 0 [:find [:pick $params ([:find $params " "]+1) [:len $params]] " "]]
} else={
	:set param3 ""
}

:put $params
:put $param1
:put $param2
:put $param3
:put $chatid
:put $from

:if ($param1="pasword") do={
/interface wireless security-profiles set mode=dynamic-keys authentication-types=wpa-psk wpa-pre-shared-key=$param3 [find name=$param2]
$send chat=$chatid text=("Profiles wireless $param2 pasword diganti menjadi $param3...") mode="Markdown"
}
:if ($param1="ssid") do={
/interface wireless set name=$param3 [find name=$param2]
$send chat=$chatid text=("SSID $param2 diganti menjadi $param3...") mode="Markdown"
}
:if ($params="count") do={
:local total [/interface wireless registration-table print count-only]
$send chat=$chatid text=("$total") mode="Markdown"
}

Leave a Reply