Jadi untuk setiap user pppoe yang login akan di bagi-bagi limitnya yaitu limit trafik youtube, limit trafik game dan limit trafik selain game dan youtube (UMUM).

Baca juga:

Address list

/ip firewall address-list
add address=192.168.0.0/16 list=private-lokal
add address=10.10.0.0/16 list=private-lokal

Raw

/ip firewall raw
add action=add-dst-to-address-list address-list=YOUTUBE address-list-timeout=\
    10m chain=prerouting content=googlevideo.com dst-address-list=\
    !private-lokal src-address-list=private-lokal
add action=add-dst-to-address-list address-list=YOUTUBE address-list-timeout=\
    10m chain=prerouting content=ytimg.com dst-address-list=!private-lokal \
    src-address-list=private-lokal
add action=add-dst-to-address-list address-list=YOUTUBE address-list-timeout=\
    10m chain=prerouting content=youtube.com dst-address-list=!private-lokal \
    src-address-list=private-lokal

Mangle

/ip firewall mangle
add action=mark-connection chain=prerouting comment=GAME dst-port="!0-1023,119\
    4,1723,1935,2083,3478,5050-5061,6666,8777,8000-8081,35915,39397" \
    new-connection-mark=GAME passthrough=yes protocol=tcp src-address-list=\
    private-lokal
add action=mark-connection chain=prerouting dst-port=!0-1023,1701,5060,5061 \
    new-connection-mark=GAME passthrough=yes protocol=udp src-address-list=\
    private-lokal
add action=mark-packet chain=prerouting connection-mark=GAME new-packet-mark=\
    "GAME PAKET" passthrough=yes
add action=mark-connection chain=prerouting comment=youtube dst-address-list=\
    YOUTUBE new-connection-mark=YOUTUBE passthrough=yes protocol=!icmp \
    src-address-list=private-lokal
add action=mark-packet chain=prerouting connection-mark=YOUTUBE \
    new-packet-mark="YOUTUBE PAKET" passthrough=yes
add action=mark-connection chain=prerouting comment=umum connection-mark=\
    no-mark new-connection-mark=UMUM passthrough=yes
add action=mark-packet chain=prerouting connection-mark=UMUM new-packet-mark=\
    "UMUM PAKET" passthrough=yes
Share to Unlock Contentimage/svg+xml

Silahkan share untuk membuka link download dan membuka scriptnya

Apabila tutorial ini bermanfaat support saya dengan cara share artikel ini.. Terimakasih 

3 COMMENTS

  1. bang, aku udah nyobain scriptnya, dan berhasil.. tp kenapa pas misal mati lampu trus hidup dan connect secara bersamaan, nama user dan ip yang ke limit jadi beda ya ?
    misal si user namanya usman dapet ip pppoe 192.168.1.10, di queue ada nama usman tp ip nya milik user lain yang gak pakek profile dengan script.

  2. bang gimana caranya biar di profile Pppoe tetap membatasi limit meskipin di pisah trafik Yt, sosmed, game,.
    Soalnya untuk cliant Ppoe saja yang tidak terlimit setelah pisah trafik Yt, Sosmed & game

    misalkan trafik Pppoe saya terlimit 4 Mbps dengan profilenya, setelah pisah Trafik kmalahan melebihi limit 4Mbps bahkan sampai 6Mbps

Leave a Reply