Ping singkatan dari Packet Internet Gopher yaitu sebuah program utilitas yang dapat digunakan untuk memeriksa Induktivitas jaringan berbasis
(TCP/IP). Ping dapat diuji apakah sebuah komputer terhubung dengan router atau dengan komputer lainnya, ini dilakukan dengan cara mengirim sebuah paket data kepada IP Address yang akan di uji coba koneksinya dan menunggu respon darinya.

Ping beroperasi dengan mengirimkan paket permintaan gema Protokol Pesan Kontrol Internet (ICMP) ke host target dan menunggu balasan gema ICMP. Program melaporkan kesalahan, kehilangan paket, dan ringkasan statistik dari hasil, biasanya termasuk minimum, maksimum, waktu pulang-pergi rata-rata, dan standar deviasi dari rata-rata.

Perintah ini tersedia untuk sistem operasi seperti Unix dan Unix, DOS (mis. FreeDOS), Microsoft Windows, ReactOS dan juga routerOS.

Script ini akan mengirimkan informasi melalui email mengenai IP Address yang akan di ping, informasi tersebut diantaranya waktu saat di ping, waktu pulang-pergi rata-rata dan presentase packet loss. Script ini dapat kita gunakan untuk monitoring IP Address client, tinggal di buatkan Scheduler/Penjadwalan atau Netwatch.

#Define Email variables here 
#Credite Steveocee Forum Mikrotik.com
:local toEmail toaddress@mikrotik.com
:local fromEmail fromaddress@mikrotik.com

#Ping Variables
:local avgRtt;

:local pin

:local pout

#Capture system identity for email subject
:local sysID [/system identity get name]

#Capture current time for logging
:local datetime "$[/system clock get date] $[/system clock get time]"


#Ping it real good
/tool flood-ping 8.8.8.8 count=10 do={
  
:if ($sent = 10) do={
    
:set avgRtt $"avg-rtt"
    
:set pout $sent
    
:set pin $received
  }

}

:local ploss (100 - (($pin * 100) / $pout))

:local logmsg ("Ping Average for 8.8.8.8 - ".[:tostr $avgRtt]."ms - packet loss: ".[:tostr $ploss]."%")

:log info $logmsg

:log info message="Emailing Ping Test Results"
delay 2
:tool e-mail send user=$fromEmail to=$toEmail subject="Pingtest results for user $sysID" body="ID: $sysID \n Test Ran at: $datetime \n Result: \n $pingit \n $logmsg"
delay 2
:log info message="Ping Test Results Have Been Emailed"

Leave a Reply