Sebelum rilis update RouterOS V6.44.1 banyak pengguna IPSec VPN di Mikrotik menggunakan opsi keamanan preshared key. Karena menggunakan opsi keamana preshared key dianggap tidak aman maka dari itu Mikrotik telah memperkenalkan lebih banyak metode otentikasi dan salah satunya adalah xauthentication.

Saat kita konfigurasi IPSec peers pada Mikrotik menggunakan opsi key yang telah diketahui sebelumnya, sebuah pesan akan muncul memberi tahu bahwa konfigurasi tidak aman. Namun, koneksi vpn akan tetap tersedia jika dikonfigurasi dengan benar di kedua sisi koneksi.

Dengan xauthentication, key secret untuk otentikasi perangkat akan diperlukan serta login dan kata sandi xauthentication. Mikrotik IPSec vpn menggunakan xauthentication memungkinkan administrator menentukan nama pengguna dan kata sandi untuk menghubungkan ke tiap klien. Namun, sisi server harus diatur ke mode pasif.

Mikrotik IPSec vpn menggunakan xauthentication

Saat menggunakan opsi xauthentication untuk peering IPSsec vpn, server diatur ke mode pasif, key secret IPSec harus dimasukkan, kemudian nama pengguna dan kata sandi IPSec yang dikonfigurasi untuk klien yang terhubung. Setiap hal lain sama dengan opsi key preshared.

Konfigurasi IPsec Di sisi Server

/ip ipsec peer
add address=192.168.1.1/32 name=user send-initial-contact=no
/ip ipsec profile
set [ find default=yes ] enc-algorithm=aes-128,3des,des hash-algorithm=sha256
add name=labkom.co.id
/ip ipsec identity
add auth-method=pre-shared-key-xauth peer=user secret=labkom.co.id xauth-login=user xauth-password=password123

Di sisi klien

Sisi klien, kita konfigurasi IPsec peers dengan login otentikasi dan password yang HARUS cocok dengan username dan password yang dikonfigurasi di server. Lihat di bawah.

/ip ipsec peer
add address=192.168.1.1/32 name=user send-initial-contact=no
/ip ipsec identity
add auth-method=pre-shared-key-xauth peer=client secret=labkom.co.id xauth-login=user xauth-password=password123

Konfigurasi IPsec Di Sisi Client

Peers pada IPsec pesan konfigurasi tidak aman menjadi hilang.

Dengan metode keamanan menggunakan xauthentication peringantan “Unsafe configuration, suggestion to use certificates” akan hilang, itu artinya konfigurasi keamnan IPsec menjadi lebih baik.