Kita bisa memantau kondisi jaringan client yang terhubung ke Wireless Mikrotik seperti informasi kekuatan sinyal yang diterima, Tx Rate, Rx Rate, IP Address dan MAC Address dari client yang terhubung melalui Wireless Mikrotik.

Pada kali ini saya mencobanya di Mikrotik hAP Lite RB941-2ND. Caranya buat schedule lalu tambahkan script ini, jangan lupa ganti dulu BOT Telegram dan Chat ID nya. Bagi yang belum punya Bot Telegram bisa kunjungi : Membuat Bot Telegram Untuk Monitoring Status Access Point Hotspot

:local output
:foreach activeIndex in=[/interface wireless registration-table find] do={
:local activeMACAddr ("*MAC Address:* ".[/interface wireless registration-table get value-name="mac-address" $activeIndex]."%0A")
:local activeUptime ("*Uptime:* ".[/interface wireless registration-table get value-name="uptime" $activeIndex]."%0A")
:local activeRate ("*TX Rate:* ".[/interface wireless registration-table get value-name="tx-rate" $activeIndex]."%0A")
:local activeRxRate ("*RX Rate:* ".[/interface wireless registration-table get value-name="rx-rate" $activeIndex]."%0A")
:local activeLast ("*IP Address:* ".[/interface wireless registration-table get value-name="last-ip" $activeIndex]."%0A")
:local activeSTN ("*Signal To Noise:* ".[/interface wireless registration-table get value-name="signal-to-noise" $activeIndex]."dB%0A")
:local activeDist ("*Distance:* ".[/interface wireless registration-table get value-name="distance" $activeIndex]."KM%0A")
:set output ($output.$activeMACAddr.$activeLast.$activeUptime.$activeRate.$activeRxRate.$activeSTN.$activeDist."%0A")
}
/tool fetch url="https://api.telegram.org/bot(BOT)/sendMessage?chat_id=(CHAT ID)&text=$output" keep-result=no

Hasilnya

Leave a Reply