Login page hotspot atau captive portal adalah sebuah halaman website yang diakses dengan browser ketika pertama kali terhubung ke sinyal wifi biasanya Captive Portal menampilkan form username dan password agar perangkat bisa mengakses internet. Bagi teman-teman yang menggunakan Mikrotik sebagai server hotspot, biasanya Login page hotspot akan otomatis muncul ketika pertama kali terhubung ke Internet, nah pada login page hotspot kita bisa menampilkan informasi total pengguna yang sedang login. Pada tutorial kali ini akan membahas langkah-langkah menampilkan total pengguna pada login page hotspot.

Menampilkan Jumlah Online Pada Login Page Hotspot

Cara Pertama

Untuk menampilkan informasi total pengguna yang sedang online yaitu dengan menggunakan script yang akan membuat file baru dengan nama on.html, kemudian file tersebut akan di load/tampilkan di halaman login page. Langkah-langkahnya sebagai berikut:

Buat script

Script ini akan membuat file baru dengan nama on.html di folder hotspot, dengan menampilkan informasi total pengguna hotspot yang aktif. Kemudian jalankan script ini di System –> Scheduler, atur sesuai dengan interval yang diinginkan.

Atau bisa juga dijalakan ketika ada user hotspot yang login dengan tambahkan script ini di hotspot user profile di on login

/system script run user-on

/ip hotspot active

:global yoi;

:global tri;

:set yoi ([/ip hotspot active print count-only])

/file set hotspot/on.html contents= \
“<html><head>User online $yoi orang</body></html>”

Edit file Login.html

Setelah script diatas dibuat dan berhasil membuat file baru dengan nama on.html, selanjutnya tampilkan halaman tersebut dengan menggunakan iframe. Seperti pada contoh dibawah ini:

<iframe src=”on.html” frameborder=”0″ scrolling=”no” marginheight=”0″ marginwidth=”4″></iframe>

Cara Kedua

Membuat file.js

Buat terlebih dahulu file dengan nama on.js dengan menggunakan notepad, kemudian pindahkan file tersebut ke file manager mikrotik di folder hotspot.

Berbeda dengan cara sebelumnya dimana file yang dibuat berextensi .html, nah kita juga bisa membuat file dengan extensi .js, caranya dengan menggunakan script dibawah ini.

/ip hotspot active
:global usr;
:set usr ([print from=[/ip hotspot active find radius=no] count-only])
/file set hotspot/on.js contents=”document.write(‘<b>$usr</b> USER’)”

Script ini akan mengupdate isi dari file on.js

Setelah script diatas dibuat selanjutnya jalankan script tersebut dengan menggunakan cara sebelumnya.

Edit file Login.html

Setelah script diatas dibuat dan berhasil membuat file baru dengan nama on.js, selanjutnya tampilkan file tersebut dengan menggunakan script dibawah ini.

<script src=”on.js”></script>

Baca juga:

4 Cara Mengatasi Login Page Hotspot tidak Otomatis Muncul

Mengatasi Login Page tidak Otomatis Muncul di Loadbalancing PCC

Nah itulah Cara Menampilkan Jumlah Online Pada Login Page Hotspot, semoga bermanfaat

2 COMMENTS

Leave a Reply